L2-006. 树的遍历

L2-006. 树的遍历

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
#include <bits/stdc++.h>
using namespace std;
struct node
{
    int data;
    struct node *l, *r;
};
struct node *creat(int *in, int *la, int n)
{
    for(int i = 0; i < n; i++)
    {
        if(in[i] == la[n-1])
        {
            node *t = new node;
            t->data = la[n-1];
            t->l = creat(in, la,i);
            t->r = creat(in + i + 1, la+i,n-(i+1));
            return t;
        }
    }
    return NULL;
};
int cnt;
void bfs(struct node *root)
{
    queue<node *>q;
    q.push(root);
    int flag = 0;
    while(!q.empty())
    {
        node *now = q.front();
        q.pop();
        if(flag)
            printf(" ");
        flag = 1;
        printf("%d",now->data);
        if(now->l != NULL)
            q.push(now->l);
            if(now->r != NULL)
            q.push(now->r);

    }
}
void inn(struct node *root)
{
    if(root)
    {
        inn(root->l);
        inn(root->r);
        printf("%d ",root->data);
    }
}

int main()
{
    int n;
    int in[100],la[100];
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
        scanf("%d", &la[i]);
    for(int i = 0; i < n; i++)
        scanf("%d", &in[i]);
    struct node *root = creat(in, la, n);
    bfs(root);
    printf("\n");
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值