1023. Have Fun with Numbers (20)

1023. Have Fun with Numbers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798
#include <cstdio>
#include <cstring>
using namespace std;
void doubleNum(char *s)
{
   int c = 0;
   int len = strlen(s);
   int sum[100];
   memset(sum, 0, sizeof(sum));
   int cnt = 0;
   int num[10];
    memset(num, 0, sizeof(num));
   for(int i = 0; i < len; i++)
   {
      num[s[i] - '0']++;
   }
   int flag = 1;

   for(int i = len - 1; i >= 0; i--)
   {
        sum[cnt++] = ((s[i] -'0')* 2 + c) % 10;
        c =  ((s[i] -'0')* 2 + c) /10;
        num[sum[cnt - 1]]--;
   }
   if(c > 0)
    sum[cnt++] = c;
   for(int i = 0; i < 10; i++)
        if(num[i] != 0)
        {
           flag = 0;
        }

    if(flag == 1)
        printf("Yes\n");
    else{
        printf("No\n");
    }
   for(int i = cnt - 1; i >= 0; i--)
   {
      printf("%d",sum[i]);
   }

}
int main()
{
     char s[100];
     scanf("%s", s);
     doubleNum(s);
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值