1017. Queueing at Bank (25)

1017. Queueing at Bank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
  int h,m,s;
  int pross;
  int sumSec;
}tim[11000];
int que[11000];
int cmp(node a, node b)
{
   return a.sumSec < b.sumSec;
}
int findMinque(int m)
{
    int M = 9999999;
    int u  = 0;
    for(int i= 0; i < m; i++)
    {
        if(que[i] < M)
        {
          M = que[i];
          u = i;
        }
    }
    return u;
}
int main()
{
   int n,m;
   scanf("%d%d", &n, &m);
   for( int i = 0; i < n; i++)
   {
      scanf("%d:%d:%d%d",&tim[i].h,&tim[i].m,&tim[i].s,&tim[i].pross);
      tim[i].sumSec = tim[i].h*3600+tim[i].m*60+tim[i].s;
   }
   sort(tim, tim+n, cmp);

   memset(que, 0, sizeof(que));
   int sum = 0;
   int eightSec = 8*60*60;
   int nightfiveSec = 17*60*60;
   int ending = 0;
   for(int i =0; i<m; i++)
   {
      que[i] = eightSec;
   }
   int num = 0;
   for( int i= 0; i < n; i++)
   {
       if(tim[i].sumSec > nightfiveSec)
           break;
         int bestque = findMinque(m);

         if(que[bestque] <= tim[i].sumSec)
         {
              que[bestque] = tim[i].sumSec + tim[i].pross*60;
         }
         else
         {
            sum += (que[bestque] - tim[i].sumSec);
            que[bestque] += tim[i].pross*60;
         }
       num++;
   }
   printf("%.1f\n",sum*1.0/(num*60));
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值