1021. Deepest Root (25)

1021. Deepest Root (25)

时间限制
1500 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:
Error: 2 components
#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
using namespace std;
#define maxn 10001
vector<int>q[maxn];
bool vis[maxn];
int deeps[maxn];
int deep;
void dfs(int now,int cnt)
{
    vis[now] = 1;

    if(deep < cnt)
    {
        deep =cnt;
    }
    int len = q[now].size();
    for(int i = 0; i < len; i++)
    {
        int to = q[now][i];
        if(vis[to] == 0)
        {
            vis[to] = 1;
            dfs(to,cnt+1);
            vis[to] = 0;
        }
    }
}

void dfs1(int now)
{
    vis[now] = 1;
    int len = q[now].size();
    for(int i = 0; i < len; i++)
    {
        int to = q[now][i];
        if(vis[to] == 0)
        {
            vis[to] = 1;
            dfs1(to);
        }
    }

}
int main()
{
    int n, m;
    int u,v;

    scanf("%d", &n);
    for(int i = 1; i < n; i++)
    {
        scanf("%d%d", &u, &v);
        q[u].push_back(v);
        q[v].push_back(u);
    }

    int maxDeep = 0;
    int flag = 0;
    int sum = 0;
    for(int i=1; i <= n; i++)
    {
        if(vis[i] == 0)
        {
            sum++;
            dfs1(i);
        }
    }
    if(sum > 1)
        flag = 1;
    if(flag == 1)
    {
        printf("Error: %d components\n",sum);

    }
    else
    {
        for( int i = 1; i <= n; i++)
        {
            memset(vis, 0, sizeof(vis));
            deep = 0;
            dfs(i,0);
            deeps[i] = deep;
            if(maxDeep < deep)
            {
                maxDeep = deep;
            }
        }
        for(int i = 1; i <= n; i++)
        {
            if(deeps[i] == maxDeep)
            printf("%d\n",i);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值