Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 56331 Accepted: 20814
Description
In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,
Ultra-QuickSort produces the output
0 1 4 5 9 .
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0
Sample Output
6
0
Source
Waterloo local 2005.02.05
题意:
给你一个n个数的数列,每次可以交换相邻两个数,求最少交换多少次可以使数列单调递增。
分析:
就是求逆序数。我们用归并排序,归并排序在合并时刚好可以很好的求出逆序数。
AC代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long
using namespace std;
int const MAX = 500005;
int a[MAX], b[MAX], n;
ll ans;
void Merge(int l, int mid, int r)
{
int i = l, j = mid + 1, k = l;
while(i <= mid && j <= r)
{
if(a[i] <= a[j])
b[k++] = a[i++];
else
{
b[k++] = a[j++];
//因为左右区间都是有序的,因此a[i]>a[j]说明a[i]~a[mid]都大于a[j]
ans += mid - i + 1;
}
}
while(i <= mid) b[k++] = a[i++];
while(j <= r) b[k++] = a[j++];
for(int s=l;s<=r;s++) a[s]=b[s];
return;
}
void Merge_sort(int l, int r)
{
if(l < r)//开始时,写成了while。。。
{
int mid = (l + r) / 2;
Merge_sort(l, mid);
Merge_sort(mid + 1, r);
Merge(l, mid, r);
}
return;
}
int main()
{
while(scanf("%d", &n) != EOF && n)
{
ans = 0;
for(int i = 0; i < n; i++)
scanf("%d", &a[i]);
Merge_sort(0, n - 1);
printf("%lld\n", ans);
}
}