(POJ 2955)Brackets 区间DP 最大括号匹配

Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6647 Accepted: 3577
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end
Sample Output

6
6
4
0
6
Source

Stanford Local 2004

题意:
给你由(,),[,]组成的字符串,从中取出一子串,问最大的括号匹配数?

分析:
求解DP的问题要从三个方面出发:子问题+最优解+极限状态。

设dp[i][j]表示字符串str[i]~str[j]的最大匹配数。

子问题:
(1)外层括号可以包含内层括号,所以当str[i],str[j]匹配时,dp[i][j] = dp[i+1][j-1] + 2;
(2)dp[i][j] 可以被分为很多不同的段的解的和值,即dp[i][j] = dp[i][k]+dp[k+1][j];

最优解:
dp[i][j] 为上面所有情况的最大值。

极限状态:
长度为1时:dp[i][i] = 0; 然后从长度为2~n开始递推出所有解。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;

char str[110];
int dp[110][110];

int main()
{
    while(scanf("%s",str) && strcmp(str,"end"))
    {
        int n = strlen(str);
        memset(dp,0,sizeof(dp));
        for(int len=2;len<=n;len++)
        {
            for(int i=0;i+len<=n;i++)
            {
                int j = i+len-1;
                if(str[i] == '(' && str[j] == ')' || str[i] == '[' && str[j] == ']')
                    dp[i][j] = max(dp[i][j],dp[i+1][j-1]+2);
                for(int k=i;k<j;k++)
                    dp[i][j] = max(dp[i][j],dp[i][k]+dp[k+1][j]);
            }
        }
        cout<<dp[0][n-1]<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值