(POJ 3041)Asteroids 二部图最大匹配 匈牙利算法

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21027 Accepted: 11421
Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
    Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.
    Sample Input

3 4
1 1
1 3
2 2
3 2
Sample Output

2
Hint

INPUT DETAILS:
The following diagram represents the data, where “X” is an asteroid and “.” is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
Source

USACO 2005 November Gold

题意:
在一个n*n的网格中,有k个小行星,每次射击可以去掉一行或一列的所有小行星,问最少射击多少次?

分析:
矩阵网格就是一个二分图。我们将各行和各列分别看做两个集合x,y;各行各列分别为一个顶点,将小行星看做行和列的联系,所以当第i行j列有小行星时,在Ri和Cj之间连接一条边。所以题目就转换成了求二分图的最小点覆盖问题了。由于定理:二分图的最小点覆盖=最大匹配数,所以我们用匈牙利算法求最大匹配。题目的数据有点大,用邻接表存储。

矩阵往往被看做是一个二部图,将行和列看做顶点,将行和列之间的联系(这题是有敌人)看做边来建图

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
using namespace std;

const int maxn=510;//x集合和y集合中元素个数的最大值
int nx,ny;//x,y集合中元素的个数
//int g[maxn][maxn];//g[i][j]=1表示xi和yj可以匹配
vector<int> g[maxn];
int cx[maxn],cy[maxn];//cx[i]表示在求得的最大匹配中与xi匹配的y顶点,cy[i]同理
int mk[maxn];//在搜索时记录是否已经访问过

int path(int u)//求增广路,每次只能使匹配数加一
{
    for(int i=0;i<g[u].size();i++)
    {
        int v=g[u][i];
        if(!mk[v])//找到一条没有匹配的边
        {
            mk[v]=1;
            if(cy[v]==-1 || path(cy[v]))//若找到一条两端都没有匹配的边则已找到。注意前面的条件满足时将不会进行递归
            {
                cx[u]=v;//更新匹配,原匹配已被覆盖
                cy[v]=u;
                return 1;
            }
        }
    }
    return 0;
}

int MaxMatch()
{
    int res=0;
    memset(cx,-1,sizeof(cx));
    memset(cy,-1,sizeof(cy));
    for(int i=1;i<=nx;i++)//每次找x中没有被覆盖的点
    {
        if(cx[i]==-1)
        {
            memset(mk,0,sizeof(mk));
            res+=path(i);
        }
    }
    return res;
}

int main()
{
    //freopen("in.txt","r",stdin);
    int T,m,u,v;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&nx,&m);
        for(int i=0;i<=nx;i++) g[i].clear();
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            g[u].push_back(v);
        }
        printf("%d\n",MaxMatch());
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值