(HDU 5922)Minimum’s Revenge 思维水题 <2016CCPC东北地区大学生程序设计竞赛 - 重现赛 >

Minimum’s Revenge
Problem Description
There is a graph of n vertices which are indexed from 1 to n. For any pair of different vertices, the weight of the edge between them is the least common multiple of their indexes.

Mr. Frog is wondering about the total weight of the minimum spanning tree. Can you help him?

Input
The first line contains only one integer T (T≤100), which indicates the number of test cases.

For each test case, the first line contains only one integer n (2≤n≤109), indicating the number of vertices.

Output
For each test case, output one line “Case #x:y”,where x is the case number (starting from 1) and y is the total weight of the minimum spanning tree.

Sample Input
2
2
3

Sample Output
Case #1: 2
Case #2: 5
Hint
In the second sample, the graph contains 3 edges which are (1, 2, 2), (1, 3, 3) and (2, 3, 6). Thus the answer is 5.

Source
2016CCPC东北地区大学生程序设计竞赛 - 重现赛

题意:
给你一棵树,有n个节点,编号从1~n,每两个节点之间都有一条边权值为两个节点编号的最小公倍数。问最小生成树的权值和为多少?

分析:
由于每个边都和编号为1的节点有连接,所以要使权值最小就是取所有与1号节点的相连的边即可。权值和为2+3+…+n,即(2+n)*(n-1)/2。
注意: 用long long

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int main()
{
    int t;
    long long n;
    int kase = 1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        long long ans = (n+2)*(n-1)/2;
        printf("Case #%d: %lld\n",kase++,ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值