(POJ 3660)Cow Contest [详解] [floyd] 传递闭包 确定top序列顺序

Cow Contest
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13189 Accepted: 7337
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

  • Line 1: A single integer representing the number of cows whose ranks can be determined
     

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5
Sample Output

2
Source

USACO 2008 January Silver

题意:
有n头牛,给出它们之间的m组胜负关系,问你有多少头牛的排名是确定的?

分析:
(1)首先,胜负关系是可以传递的,即a胜于b,b胜于c,那么a胜于c

(2)如何知道某头牛的名次是确定的呢?
若已知牛a胜于m头牛,且负余k头牛,m + k == n-1,那么我们一定可以确定牛a的排名是:k+1.
换句话说就是,我们只需要找出胜于牛a的牛的数目m,和负于牛a的牛的数目k,然后判断m + k == n-1?是否成立即可。

(3)若牛a胜于牛b,则在建图时添加一条a->b的有向边,那么“胜于”关系就转化成了“可达”关系了。我们只需要知道每一点的可达和被可达关系数目之和,就可以解决此问题了。

由于要知道任意两点之间的“可达”关系,所以使用floyd算法方便实现。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;

const int maxn = 110;
int win[maxn][maxn];
int n,m;

void floyd()
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(win[i][k] && win[k][j]) win[i][j] = 1;  //i可达j
            }
        }
    }
}

int main()
{
    int u,v;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(win,0,sizeof(win));
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            win[u][v] = 1;
        }
        floyd();
        int ans = 0;
        for(int i=1;i<=n;i++)
        {
            int num = 0;
            for(int j=1;j<=n;j++)
            {
                if(i == j) continue;
                if(win[i][j] || win[j][i]) num++;
            }
            if(num == n-1) ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值