HDU1011——Starship Troopers(树形dp)

**

HDU1011 Starship Troopers

**

若有错误,烦请指出,不胜感激

Description

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern’s structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers – the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1’s.

Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

Sample Input

5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1

Sample Output

50
7

题意

有n个房间,每个房间有一定量的虫子和价值,你有m个士兵,每个士兵可抵20个虫子,且不能重复使用,每去一个房间,必须要留足够的士兵清除所有虫子,就算里面没有虫子也必须要派士兵经过这个房间(一定要注意这里),问你能得到的最大价值是多少

思路

双向建图,用dp[i][j]表示用j个兵能在以i为根的子树上可获得的最大价值。具体看代码

代码

#include<iostream>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<vector>
using namespace std;
#define maxn 101
struct Edge{
    int v, next;
}edge[maxn*2];
int cnt, head[maxn], dp[101][101], n, m;
int vis[101];
int v[101], w[101];
void add_edge(int u, int v){
    edge[cnt].v = v;
    edge[cnt].next = head[u];
    head[u] = cnt++;
}
void dfs(int u){
    int now = v[u];
    vis[u] = 1;
    for(int i = head[u]; i != -1; i = edge[i].next){
        int to = edge[i].v;
        if(vis[to]) continue;
        dfs(to);
        for(int j = m; j >= now; j--){
            for(int k = 1; k <= j-now; k++){  //注意这里是以1开始的,以0开始必错,以为要派士兵经过房间,所以子节点处至少为1
                dp[u][j] = max(dp[u][j], dp[u][j-k]+dp[to][k]);
            }
        }
    }
}


int main(){
    int i, j, k, x, y;
    while(scanf("%d%d",&n,&m)!=EOF){
        cnt = 0;
        memset(dp, 0, sizeof(dp));
		memset(vis, 0, sizeof(vis));
        memset(head, -1, sizeof(head));
        if(n==-1 && m==-1) break;
        for(i = 1; i <= n; i++){
            scanf("%d%d",&v[i],&w[i]);
            v[i] = (v[i]+19)/20;
            for(j = v[i]; j <= m; j++) dp[i][j] = w[i];
        }
        for(i = 1; i < n; i++){
            scanf("%d%d",&x,&y);
            add_edge(x, y);
            add_edge(y, x);
        }
        if(m==0){  //注意这里,m为0要特判
        	printf("0\n");
        	continue;
        }
        dfs(1);
        printf("%d\n",dp[1][m]);
    }
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值