Online Judge

Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user's result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return "Accepted", else if the only differences between the two files are spaces(' '), tabs('\t'), or enters('\n'), the Judge System should return "Presentation Error", else the system will return "Wrong Answer".

Given the data of correct output file and the data of user's result file, your task is to determine which result the Judge System will return.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case has two parts, the data of correct output file and the data of the user's result file. Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.

Output

For each test cases, you should output the the result Judge System should return.

Sample Input

4
START
1 + 2 = 3
END
START
1+2=3
END
START
1 + 2 = 3
END
START
1 + 2 = 3

END
START
1 + 2 = 3
END
START
1 + 2 = 4
END
START
1 + 2 = 3
END
START
1	+	2	=	3
END

Sample Output

Presentation Error
Presentation Error
Wrong Answer
Presentation Error
解题报告:
这个题的题意是模拟oj检测判题系统格式的原理,即给出输入输入,判断错误类型 
这里输入可能有点问题,现补充一点关于字符串的知识
gets()函数用来从标准输入设备(键盘)读取字符串直到回车结束, 但回车符
不属于这个字符串。其调用格式为:
    gets(s);
    其中s为字符串变量(字符串数组名或字符串指针)。
    gets(s)函数与scanf("%s", &s)相似, 但不完全相同, 使用scanf("%s", &s)
函数输入字符串时存在一个问题, 就是如果输入了空格会认为输入字符串结束,
空格后的字符将作为下一个输入项处理, 但gets() 函数将接收输入的整个字符
串直到回车为止。
#include<stdio.h>
#include<string.h>
#define N 5050
char a1[N],b1[N];
char a2[N],b2[N];
char tmp[N];

void input(char *a,char *b)
{
    gets(tmp);  //先接收一系列字符,直到输入回车时结束 
    
    while(strcmp(tmp,"START")!=0) //当接收的字符串不是start继续接收 
        gets(tmp);
        
    while(gets(tmp))
	{
        if(strcmp(tmp,"END")==0)    //当接受的字符串时end的时候,跳出循环 
            break;
        if(strlen(tmp)!=0)
            strcat(a,tmp);
        strcat(a,"\n");
    }
    
    int t=0,len=strlen(a);
    
    for(int i=0;i<len;i++)
        if(a[i]!=' ' && a[i]!='\t' && a[i]!='\n')    //b为a去了三种格式之后的 
            b[t++]=a[i];
            
    b[t]='\0';
    
}

int main(){
    int n;
    scanf("%d",&n);
    while(n--){
        a1[0]='\0';
        a2[0]='\0';
        
        input(a1,b1);      //a1为第一次输入的 
        input(a2,b2);     //a2为要对比的 
        
        if(strcmp(a1,a2)==0)    //如果两个字符串在去除空格之前完全相等 
            printf("Accepted\n");
        else if(strcmp(b1,b2)==0)    //如果两个字符串不相等,但是去除了三种之后相等,则是pe,因为只有那三种不一样 
            printf("Presentation Error\n");
        else     //两个字符串不相等,去除了三种情况之后也不相等,则是wa 
            printf("Wrong Answer\n");
    }
    return 0;
}


另外一种写法:
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

char s1[5050],s2[5050],c,s3[5050],s4[5050],s[5050];
char q1[10]={"START"},q2[10]={"END"};  //用两个数组存关键字符,判断是否开始输入和结束

int main()
{
    int l1,l2,t,i,j;
    cin>>t;
    while(t--)
    {
        memset(s1,0,sizeof(s1));
        memset(s2,0,sizeof(s2));
        memset(s3,0,sizeof(s3));
        memset(s4,0,sizeof(s4));
        while(cin>>s&&strcmp(s,q1));   //while为真才往下执行,否则一直停留在这个语句 
        while(1)
		{
            memset(s,0,sizeof(s));
            gets(s);
            if(strcmp(s,q2)==0)   //如果接收到end跳出 
			{
                break;
            }
            if(strlen(s))     //如果输入字符串的长度不为0,把输入的接在‘0’后面 
                strcat(s1,s); //字符串连接函数,将后一个字符串接在前一个的后面 
            else
                strcat(s1,"\n"); 
        }
        while(cin>>s&&strcmp(s,q1));  //输入答案,一样的道理 
        while(1)
		{
            memset(s,0,sizeof(s));
            gets(s);
            if(strcmp(s,q2)==0){
                break;
            }
            if(strlen(s))
                strcat(s2,s);
            else
                strcat(s2,"\n");
        }
        l1=strlen(s1);
        l2=strlen(s2);
        if(strcmp(s1,s2)==0)   //两个字符串完全相符 
		{
            cout<<"Accepted"<<endl;  
            continue;
        }
        for(i=0,j=0;i<l1;i++)
		{
            if(s1[i]!=' '&&s1[i]!='\t'&&s1[i]!='\n')  //把除了tab,空格,回车之外的字符放进另一个数组里面 
                s3[j++]=s1[i];
        }
        for(i=0,j=0;i<l2;i++)
		{
            if(s2[i]!=' '&&s2[i]!='\t'&&s2[i]!='\n')
                s4[j++]=s2[i];
        }
        if(strcmp(s3,s4))
            cout<<"Wrong Answer"<<endl;   
        else
            cout<<"Presentation Error"<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值