8.11 D - Period

                                           D - Period


For each prefix of a given string S with N characters(each character has an ASCII code between 97 and 126, inclusive), we want toknow whether the prefix is a periodic string. That is, for each i (2 <= i<= N) we want to know the largest K > 1 (if there is one) such that theprefix of S with length i can be written as A K,that is Aconcatenated K times, for some string A. Of course, we also want to know theperiod K.


Input

The input consists of several test cases. Each test caseconsists of two lines. The first one contains N (2 <= N <= 1 000 000) –the size of the string S.The second line contains the string S. The input fileends with a line, having the 
number zero on it.


Output

For each test case, output "Test case #" andthe consecutive test case number on a single line; then, for each prefix withlength i that has a period K > 1, output the prefix size i and the period Kseparated by a single space; the prefix sizes must be in increasing order.Print a blank line after each test case.


Sample Input

3

aaa

12

aabaabaabaab

0


Sample Output

Test case #1

2 2

3 3

 

Test case #2

2 2

6 2

9 3

12 4

 

题意:输入一个数字n,然后输入长度为n的一个字符串,然后从前往后判断循环节,当某一位字符前含有2个循环节时,输出当前为第几个字符,并输出循环节的个数,例如aabaabaabaab,判断到第二个字符时,有两个循环节,单循环节为a,所以输出2 2,到第六个字符时,也有两个循环节,单循环节为aad,所以输出6 2,以此类推,输出全部符合条件的数据。输出的样例之间含有换行。


#include<stdio.h>
#include<string.h>
int next[1110000];
char s[1100000];
int main()
{
	int i,j,k,m,n,w,z=1;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
		break;
		getchar();
		for(i=0;i<n;i++)
			scanf("%c",&s[i]);
			
	//	puts(s);
		i=0;j=-1;
		next[0]=-1;
		while(i<n)
		{
			if(j==-1||s[i]==s[j])
			{
				i++;
				j++;
				next[i]=j;
			}
			else
			{
				j=next[j];
			}
		}
/*		for(i=0;i<=n;i++)
		{
			printf("%d ",next[i]);
		}
		printf("\n");
*/	//	if(z!=1)
		
		printf("Test case #%d\n",z++);
		for(i=2;i<=n;i++)
		{
			w=i-next[i];//判断单个循环节长度
			
			if(next[i]%w==0&&w!=0)//当存在符合条件的循环节时
			{
				if(next[i]/w+1!=1)//计算是否含有2个以上循环节
				printf("%d %d\n",i,next[i]/w+1);
			}
		}
		
		printf("\n");
		
	}
	
	return 0;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值