HDU 2458 Kindergarten 二分匹配

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
InputThe input consists of multiple test cases. Each test case starts with a line containing three integers 
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and 
the number of pairs of girl and boy who know each other, respectively. 
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other. 
The girls are numbered from 1 to G and the boys are numbered from 1 to B. 

The last test case is followed by a line containing three zeros.OutputFor each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.Sample Input
2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0
Sample Output
Case 1: 3
Case 2: 4

题意:n个男生和m个女生存在k条关系,找出这些关系中的最大团,输出团的大小。

思路:二分匹配模板题,人数总和减去最大匹配即可。

#include<stdio.h>
#include<string.h>
int s[300][300];
int a[300],next[300];
int m,n;
int add(int x)
{
	int i,j;
	for(i=1;i<=n;i++)
	{
		if(s[x][i]==0&&next[i]==0)
		{
			next[i]=1;
			if(a[i]==0||add(a[i]))
			{
				a[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,k,t,u,v;
	int z=1;
	while(scanf("%d%d%d",&m,&n,&t)!=EOF)
	{
		if(m+n+t==0)
			break;
		memset(s,0,sizeof(s));
		memset(a,0,sizeof(a));
		for(i=1;i<=t;i++)
		{
			scanf("%d%d",&u,&v);
			s[u][v]=1;
		}
		int sum=0;
		for(i=1;i<=m;i++)
		{
			memset(next,0,sizeof(next));
			if(add(i)==1)
				sum++;
		}
	/*	for(i=1;i<=n;i++)
		{
			printf("%d  ",a[i]);
		}*/
		printf("Case %d: ",z++);
		printf("%d\n",m+n-sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值