Kindergarten(二分匹配之二分图的最大团)

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
Input
The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.
Output
For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

题意分析:这道题的意思就是一位老师想要找一些相互都认识的同学组成一个团来做游戏,问老师可以选择的最多学生数量是多少,即学生组成的这个团最多有多少人。
解题思路:这道题就是二分匹配思想的逆向思维,正面去求的话,你需要求出每个女生最多能跟多少男生组成一个团,和每个男生最多可以和多少女生组成团,然后取二者的最大值,比较麻烦,所以就反过来想,将本来认识的人变为不认识,不认识的人变为认识,然后求原本不认识的人的最大匹配数,用总人数减去不认识的人的最大匹配数就是相互认识的人的总数。
二分图的最大团=补图的最大独立集

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
int match[20000],book[20000],n,m,e[2000][2000];
int dfs(int u)
{
	int i;
	for(i=1;i<=m;i++)
	{
		if(book[i]==0&&e[u][i]==1)
		{
			book[i]=1;
			if(match[i]==0||dfs(match[i]))
			{
				match[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,sum,r,t1,t2,r1=0;
	while(scanf("%d%d%d",&n,&m,&r),n!=0||m!=0||r!=0)
	{
		r1++;
		memset(match,0,sizeof(match));
		sum=0;
		//初始化所有的的人当初都是认识的。
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				e[i][j]=1;
		for(i=1;i<=r;i++)
		{
			scanf("%d%d",&t1,&t2); 
			e[t1][t2]=0;	//将本来互相认识的人变为不认识。
		}
		for(i=1;i<=n;i++)
		{
			memset(book,0,sizeof(book));
			if(dfs(i))
				sum++;//求原本不认识人的最大匹配数
		}
		printf("Case %d: %d\n",r1,n+m-sum);
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值