BZOJ1646[Usaco2007 Open] 抓住那头牛

原题链接:http://www.lydsy.com/JudgeOnline/problem.php?id=1646
一本通链接:http://ybt.ssoier.cn:8088/problem_show.php?pid=1253

抓住那头牛

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 <= N <= 100,000) on a number line and the cow is at a point K (0 <= K <= 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X-1 or X+1 in a single minute * Teleporting: FJ can move from any point X to the point 2*X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

农夫约翰被通知,他的一只奶牛逃逸了!所以他决定,马上幽发,尽快把那只奶牛抓回来.

他们都站在数轴上.约翰在N(O≤N≤100000)处,奶牛在K(O≤K≤100000)处.约翰有两种办法移动,步行和瞬移:步行每秒种可以让约翰从z处走到x+l或x-l处;而瞬移则可让他在1秒内从x处消失,在2x处出现.然而那只逃逸的奶牛,悲剧地没有发现自己的处境多么糟糕,正站在那儿一动不动.

那么,约翰需要多少时间抓住那只牛呢?

Input

Line 1: Two space-separated integers: N and K

仅有两个整数N和K.

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

最短的时间.

Sample Input

5 17

Farmer John starts at point 5 and the fugitive cow is at point 17.

Sample Output

4

OUTPUT DETAILS:

The fastest way for Farmer John to reach the fugitive cow is to

move along the following path: 5-10-9-18-17, which takes 4 minutes.

题解

bfs裸题,巨水不解释。

代码
#include<bits/stdc++.h>
using namespace std;
const int M=1e5+5;
int p1=1,p2=1;
int n,k;
bool sq[M];
int step[M][2];
int main()
{
    scanf("%d%d",&n,&k);
    sq[n]=1;
    step[1][1]=n;
    int maxn=max(n,k)+1;
    if(n==k)printf("0"),exit(0);
    while(p1<=p2)
    {
        int a;
        for(int i=1;i<=3;i++)
        {
            if(i==1)a=step[p1][1]-1;
            if(i==2)a=step[p1][1]+1;
            if(i==3)a=step[p1][1]*2;
            if(a<0||a>maxn)continue;
            if(sq[a]==0)
            {
                p2++;
                sq[a]=1;
                step[p2][1]=a;
                step[p2][0]=step[p1][0]+1;
                if(a==k)
                {
                    printf("%d\n",step[p2][0]);
                    return 0;
                }
            }
        }
        p1++;
    }
    return 0;
}

凯老师神奇的dp版

#include<cstdio>
#include<queue>
using namespace std;
int dp[100005];
int n,k;
struct no{
    int pl,step;
};
queue<no> q;
void BFS(){
    q.push((no){n,1});
    dp[n]=1;
    while(!q.empty()){
        if(dp[k]!=0) {
            printf("%d",dp[k]-1);return;
        }
        no u=q.front();q.pop();
        if(u.pl+1<=100000&&dp[u.pl+1]==0){
            dp[u.pl+1]=u.step+1;
            q.push((no){u.pl+1,u.step+1});
        }
        if(u.pl-1>=0&&dp[u.pl-1]==0){
            dp[u.pl-1]=u.step+1;
            q.push((no){u.pl-1,u.step+1});
        }
        if((u.pl<<1)<=100000&&dp[u.pl<<1]==0){
            dp[u.pl<<1]=u.step+1;
            q.push((no){u.pl<<1,u.step+1});
        }
    }
}
int main(){
    scanf("%d%d",&n,&k);
    BFS();
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ShadyPi

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值