HDU Prime Ring Problem(深度优先搜索)

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8


Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

 

大致提议,给你n个数字构成一个环,相邻的两个数的和的为素数。

注意输入1的时候输出1,尽管1不是素数。另外每组数据之间个空行。

这是典型的要用深度优先搜索的题目。不断匹配每个位。

其实很简单。

 

AC代码:

 

 

# include <cstdio>
# include <cstring>
using namespace std;
int vis[50], prime[50], a[50], ans[50], used[50];
int n, t;
void dfs(int cur){
	if(cur>n){
		for(int i=1; i<=n-1; i++){
			printf("%d ", ans[i]);
		}
		printf("%d\n", ans[n]);
		return;
	}
	if(cur!=n)
	for(int i=2; i<=n; i++){
		if(!used[i]&&prime[ans[cur-1]+i]){
			used[i]=1;
			ans[cur]=i;
			dfs(cur+1);
			used[i]=0;
		}
	}
	else
	for(int i=2; i<=n; i++){
		if(!used[i]&&prime[ans[cur-1]+i]&&prime[ans[1]+i]){//最后一个判断下
			used[i]=1;           
			ans[cur]=i;
			dfs(cur+1);
			used[i]=0;
		}
	}
}
int main(){
	int i, j, k;
    for(i=2; i<=40; i++){//筛法求素数
    	if(!vis[i]){
    		prime[i]=1;
    		for(j=i+i; j<=40; j=j+i){
    			vis[j]=1;
			}
		}
	}
	t=0;
	while(scanf("%d", &n)!=EOF){
		if(n==1){
			printf("Case %d:\n", ++t);
			printf("1\n\n");
			continue;
		}
		ans[1]=1;
		memset(used, 0, sizeof(used));
		printf("Case %d:\n", ++t);
		dfs(2);//深度优先搜索
		printf("\n");
	}
	return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值