1004 Counting Leaves (30分)

1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

 VECTOR容器常用方法
 vector<int>name 构造空容器 int可换成其他类型.
 vector<type>name(n)如果是基本数据类型,则默认初始化n个元素全为0
 vector<int>name(n, t)构造一个由n个t元素构成的容器实例name
 name.clear()清空容器中的元素
 s1.swap(s2)交换两个容器的内容
 name.size()元素个数
 name。empty()是否为空,返回bool
 name.resize(n)将容器大小变为n
 name.push_back(元素)将元素推进容器
 name.pop_back() 将最后一个元素删除
#include <iostream>
#include <vector>
#include <string>
#include <cstring>
using namespace std;
#define MAX 100
#define bigger(a,b) a>b?a:b
vector<int>obj[100];
int leaves[MAX];
int max_depth;
void DFS(int num, int depth){
    if(obj[num].size() == 0){
        leaves[depth]++;
        max_depth = bigger(max_depth, depth);
        return ;
    }
    for(int i=0; i< obj[num].size(); i++){
        DFS(obj[num][i], depth+1);
    }
}
int main()
{
    int n, m;
    int id, k, child;
    cin >> n >> m;
    
    for(int i=0; i<m; i++){
        cin >> id >> k;
        for(int j=0; j<k; j++){
            cin >> child;
            obj[id].push_back(child);
        }
    }
    DFS(1, 0);
    cout << leaves[0];
    for(int i=1; i<=max_depth; i++){
        cout << ' ' << leaves[i];
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值