hdu6047



Maximum Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 856    Accepted Submission(s): 401


Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}:  an+1a2n . Just like always, there are some restrictions on  an+1a2n : for each number  ai , you must choose a number  bk  from {bi}, and it must satisfy  ai ≤max{ aj -j│ bk ≤j<i}, and any  bk  can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{ 2nn+1ai } modulo  109 +7 .

Now Steph finds it too hard to solve the problem, please help him.
 

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.
 

Output
For each test case, print the answer on one line: max{ 2nn+1ai } modulo  109 +7。
 

Sample Input
      
      
4 8 11 8 5 3 1 4 2
 

Sample Output
      
      
27
思路:另建一个数组,来存储前面i 位的最大值,这样就可以用b[i]来扫而且,

Maximum Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 856    Accepted Submission(s): 401


Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}:  an+1a2n . Just like always, there are some restrictions on  an+1a2n : for each number  ai , you must choose a number  bk  from {bi}, and it must satisfy  ai ≤max{ aj -j│ bk ≤j<i}, and any  bk  can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{ 2nn+1ai } modulo  109 +7 .

Now Steph finds it too hard to solve the problem, please help him.
 

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.
 

Output
For each test case, print the answer on one line: max{ 2nn+1ai } modulo  109 +7。
 

Sample Input
       
       
4 8 11 8 5 3 1 4 2
 

Sample Output
       
       
27
思路:可以再建一个数组来存储前i位的最大值,第n+1位绝对是后面中的最大一个,所以可以直接扫数组b。
代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <cmath>
#include <stdlib.h>
#include <vector>
#include <queue>
#include <stack>
using namespace std;
const int MOD=1e9+7;
vector<int>a1;
vector<int>a2;
int v[100005];
int a[250005],b[250005];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int i;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            a[i]-=i;
        }
        for(i=1;i<=n;i++)
        {
            scanf("%d",&b[i]);
        }
        sort(b+1,b+n+1);
        int c[250005];
        c[n]=a[n];
        for(i=n-1;i>=1;i--)
        {
            if(a[i]>c[i+1])
            {
                c[i]=a[i];
            }
            else c[i]=c[i+1];
        }
        int d=c[b[1]];
        int e=d-n-1;
        long long int ans=0;
        ans=(ans+d)%MOD;
        for(i=2;i<=n;i++)
        {
            d=c[b[i]];
            d=max(e,d);
            ans=(ans+d)%MOD;
        }
        cout<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值