POJ 1068 - Parencodings

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24828 Accepted: 14627
Description

Let S = s1 s2…s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2…pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2…wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S       (((()()())))

P-sequence      4 5 6666

W-sequence      1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9
Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

给出一行括号,可以用数字量化,即从左到右遍历中,右括号左边有多少个左括号。

题目要求根据这一行括号,分别输出各个括号里面包含的左括号(包括其自身括号)

解题思路:
先是把这些存到char数组里,然后从左到右遍历,如果遇到右括号,那就从这个右括号向左开始遍历,遇到的第一个左括号停止,期间把走过的路径都标志掉,记录下走的步数,然后(step+1)2,就是左括号的个数.

AC代码

#include<stdio.h>
#include<string.h>
int main()
{
    char s[100];
    int n[100];
    int r[100];
    int loop;
    scanf("%d",&loop);
    while(loop--)
    {
        int sum;
        int i;
        scanf("%d",&sum);
        for(i = 1;i <= sum;i++)
            scanf("%d",&n[i]);
        n[0] = 0;
        int j;
        int s_index = 0;
        for(i = 1;i <= sum;i++)
        {
            for(j = 1;j <= n[i]-n[i-1];j++)
                s[s_index++] = '(';
            s[s_index++] = ')';
        }
        s[s_index] = '\0';
        int r_index = 0;
        int step = 0;
        for(i = 0;i <= s_index-1;i++)
        {
            step = 0;
            if(s[i] == ')')
            {
                j = i;
                while(j>=0)
                {
                    if(s[j] == '(')
                        {
                            s[j] = 0;
                            break;
                        }
                    s[j] = 0;
                    j--;
                    step++;
                }
            r[r_index++] = (step+1)/2;
            }
        }
        for(i = 0;i < r_index;i++)
        {
            if(!i)
                printf("%d",r[i]);
            else
                printf(" %d",r[i]);
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值