HDU 5808 - NanoApe Loves Sequence(模拟)

NanoApe Loves Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 1365 Accepted Submission(s): 530

Problem Description
NanoApe, the Retired Dog, has returned back to prepare for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with n numbers on the paper and then randomly deleted a number in the sequence. After that, he calculated the maximum absolute value of the difference of each two adjacent remained numbers, denoted as F.

Now he wants to know the expected value of F, if he deleted each number with equal probability.

Input
The first line of the input contains an integer T, denoting the number of test cases.

In each test case, the first line of the input contains an integer n, denoting the length of the original sequence.

The second line of the input contains n integers A1,A2,…,An, denoting the elements of the sequence.

1≤T≤10, 3≤n≤100000, 1≤Ai≤109

Output
For each test case, print a line with one integer, denoting the answer.

In order to prevent using float number, you should print the answer multiplied by n.

Sample Input
1
4
1 2 3 4

Sample Output
6

题意:
给出n个数,每次随机拿走一个数,求剩下的数中相邻的数的差的绝对值最大的期望。
最后防止出现小数,对结果乘n。

解题思路:
设Fi是1到i中相邻的数的差的绝对值的最大值。
Gi是i到n中相邻的数的差的绝对值的最大值。
那么对于每一个数,他的结果就是max(Fi-1,Gi+1,abs(Ai-1 - Ai+1))
最后对n个结果求和即可。

AC代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+5;
long long a[maxn];
long long f[maxn];
long long g[maxn];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i = 1;i <= n;i++)   scanf("%lld",&a[i]);
        memset(f,0,sizeof(0)),memset(g,0,sizeof(g));
        for(int i = 2;i <= n;i++)   f[i] = max(f[i-1],abs(a[i]-a[i-1]));
        for(int i = n-1;i >= 1;i--) g[i] = max(g[i+1],abs(a[i]-a[i+1]));
//        for(int i = 1;i <= n;i++)   printf("%lld ",f[i]);
//        putchar('\n');
//        for(int i = 1;i <= n;i++)   printf("%lld ",g[i]);
//        putchar('\n');
        a[0] = a[2];
        a[n+1] = a[n-1];
        long long res = 0;
        for(int i = 1;i <= n;i++)   res += max(max(f[i-1],g[i+1]),abs(a[i-1]-a[i+1]));
        printf("%lld\n",res);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值