POJ1141 Brackets Sequence【区间DP+递归】

Brackets Sequence

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 34575 Accepted: 10007 Special Judge

Description

Let us define a regular brackets sequence in the following way: 

1. Empty sequence is a regular sequence. 
2. If S is a regular sequence, then (S) and [S] are both regular sequences. 
3. If A and B are regular sequences, then AB is a regular sequence. 

For example, all of the following sequences of characters are regular brackets sequences: 

(), [], (()), ([]), ()[], ()[()] 

And all of the following character sequences are not: 

(, [, ), )(, ([)], ([(] 

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]

Source

Northeastern Europe 2001

问题链接:POJ1141 Brackets Sequence

解题思路:https://blog.csdn.net/cc_again/article/details/10169643

AC的C++程序:

#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;

const int N=110;
const int INF=99999;
int dp[N][N],path[N][N];
char s[N];

//递归打印 
void print(int l,int r)
{
	if(l>r)
	  return;
	if(l==r)
	{
		if(s[l]=='('||s[l]==')')
		  printf("()");
		else
		  printf("[]");
		return;
	}
	if(path[l][r]==-1)//首尾,先输出开始部分,然后递归输出中间,最后输出结尾部分 
	{
		printf("%c",s[l]);
		print(l+1,r-1);
		printf("%c",s[r]);	
	}
	else
	{
		print(l,path[l][r]);//直接递归输出两部分
		print(path[l][r]+1,r); 
	}
}

int main()
{
	while(gets(s))
	{
		int n=strlen(s);
		memset(dp,0,sizeof(dp));
		for(int i=0;i<n;i++)//只有一个的话只需要再添加对应的一个即可 
		  dp[i][i]=1;
		for(int len=1;len<n;len++)
		  for(int i=0,j=len;j<n;i++,j++)
		  {
		  	dp[i][j]=INF;
		  	if((s[i]=='['&&s[j]==']')||(s[i]=='('&&s[j]==')'))
		  	  if(dp[i+1][j-1]<dp[i][j])
		  	  {
		  	  	dp[i][j]=dp[i+1][j-1];
		  	  	path[i][j]=-1;
			  }
			//遍历各个断点 
		  	for(int k=i;k<j;k++)
		  	  if(dp[i][k]+dp[k+1][j]<dp[i][j])
			  {
			  	dp[i][j]=dp[i][k]+dp[k+1][j];
			  	path[i][j]=k;
			   } 
		  }
		print(0,n-1);
		printf("\n");
	}
	return 0;	
} 
 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值