Brackets Sequence

Description

Let us define a regular brackets sequence in the following way: 

1. Empty sequence is a regular sequence. 
2. If S is a regular sequence, then (S) and [S] are both regular sequences. 
3. If A and B are regular sequences, then AB is a regular sequence. 

For example, all of the following sequences of characters are regular brackets sequences: 

(), [], (()), ([]), ()[], ()[()] 

And all of the following character sequences are not: 

(, [, ), )(, ([)], ([(] 

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]

这题是通过字符的长度开始递归,起始时每个字符都需要一个字符来和其进行配对,故都为1,之后不断增加长度,如果起始的和结束的正好可以配对,那dp[i][j]=dp[i+1][j-1],如果无法正好配对,那就看dp[i][k]+dp[k+1][j]的值把他拆分下来看,这样一直找下去,可以找到每一个字符到另一个字符所需要添加的最短的字符数目,和由哪两段区间的值合并而成;之后就由1到n开始,向下不断查找,一直到单个或者正好成对的区间,然后输出,之后继续搜索,直到全部输出完毕。

#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<bitset>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int INF=0x3f3f3f3f;

char str[110];
int dp[110][110];
int pos[110][110];

void show(int start,int end)
{
	if(start>end)
		return ;
	if(start==end)
	{
		if(str[start]=='('||str[start]==')')
			printf("()");
		if(str[start]=='['||str[start]==']')
			printf("[]");
	}
	else 	
	{
		if(pos[start][end]==-1)
		{
			if(str[start]=='(')
			{
				printf("(");
				show(start+1,end-1);
				printf(")");
			}
			if(str[start]=='[')
			{
				printf("[");
				show(start+1,end-1);
				printf("]");
			}
		}
		else
		{
			show(start,pos[start][end]);
			show(pos[start][end]+1,end);
		}
	}
}
int main()
{
	scanf("%s",str);
	int n=strlen(str);
	int i,k,d;
	for(i=n-1;i>=0;i--)
	{
		str[i+1]=str[i];
		dp[i+1][i+1]=1;
	}
	for(d=1;d<=n-1;d++)
		for(i=1;i<=n-d;i++)
		{
			dp[i][i+d]=INF;					//
			if((str[i]=='('&&str[i+d]==')')||(str[i]=='['&&str[i+d]==']'))
			{
				if(dp[i+1][i+d-1]<dp[i][i+d])
					dp[i][i+d]=dp[i+1][i+d-1];
			}
			pos[i][i+d]=-1;
			for(k=i;k<i+d;k++)
			{
				if((dp[i][k]+dp[k+1][i+d])<dp[i][i+d])
				{
					pos[i][i+d]=k;
					dp[i][i+d]=dp[i][k]+dp[k+1][i+d];	
				}
			}
		}
	show(1,n);
	printf("\n");
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值