1016 Phone Bills (25 分)

 

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

C:

/*
 @Date    : 2017-11-29 19:41:48
 @Author  : 酸饺子 (changzheng300@foxmail.com)
 @Link    : https://github.com/SourDumplings
 @Version : $Id$
*/

/*
https://www.patest.cn/contests/pat-a-practise/1016
分析:
    来自:http://www.th7.cn/Program/cp/201402/174424.shtml
  模拟题,提交无数次WA,注意几点:
  1.如果某人没有有效通话记录,则不输出该人的信息,在此WA15次,题目看了N遍也没出现啊。
  2.通话时间钱的计算:假设我们计算time1到time2的账单;
  (1)我们可以采用从起点(即00:00:00)开始计算,结果就是get_money(time2) - get_money(time1), 这样计算方便。
  (2)我们也可以采用从time1开始递增直到time2, 这样比较烦。
  3.有效的通话记录是指:如果某人的通话记录为1.on;2.on;3.off;,则其中1.on将被抛弃,匹配到2.on;3.off;。
 */

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

double rate[24];
int N;

typedef struct RECORD *Record;
struct RECORD
{
    char name[21];
    int m, d, h, min;
    int status; // 0表示on-line, 1表示off-line;
};

int compare(const void *a, const void *b)
{
    a = (Record *)a;
    b = (Record *)b;
    int k;
    if (strcmp((*(Record *)a)->name, (*(Record *)b)->name) == 0)
    {
        if ((*(Record *)a)->m - (*(Record *)b)->m == 0)
        {
            if ((*(Record *)a)->d - (*(Record *)b)->d == 0)
            {
                if ((*(Record *)a)->h - (*(Record *)b)->h == 0)
                {
                    k = (*(Record *)a)->min - (*(Record *)b)->min;
                }
                else
                {
                    k = (*(Record *)a)->h - (*(Record *)b)->h;
                }
            }
            else
            {
                k = (*(Record *)a)->d - (*(Record *)b)->d;
            }
        }
        else
        {
            k = (*(Record *)a)->m - (*(Record *)b)->m;
        }
    }
    else
    {
        k = strcmp((*(Record *)a)->name, (*(Record *)b)->name);
    }
    return k;
}

double GetMoney(Record stop)
{
    double charge = 0;
    double d_money = 0;
    double h_money = 0;
    int i;
    for (i = 0; i < 24; i++)
    {
        d_money += rate[i] * 60;
    }
    for (i = 0; i < stop->h; i++)
    {
        h_money += rate[i] * 60;
    }
    charge = d_money * stop->d + h_money + stop->min * rate[stop->h];
    return charge;
}

double CalcEachCom(Record start, Record end, int *ptotalmin)
{
    *ptotalmin = (end->d - start->d) * 24 * 60 + (end->h - start->h) * 60 + end->min - start->min;
    double charge = 0;
    charge = GetMoney(end) - GetMoney(start);
    return charge;
}

void OutPut(Record data[])
{
    int i;
    Record temp = NULL;
    double charge = 0, amount = 0;
    char nowoutputingname[21];
    char lastoutputname[21];
    int eachmin;
    int isoutput = 0;
    for (i = 0; i < N; i++)
    {
        if (data[i]->status == 0)
        {
            // 遇到一条on-line的记录
            temp = data[i];
            strcpy(nowoutputingname, temp->name);
        }
        else
        {
            // 一条off-line的记录
            if (temp && strcmp(nowoutputingname, data[i]->name) == 0)
            {
                // 如果前面对应着同一个人的一条on-line记录
                if (strcmp(nowoutputingname, lastoutputname))
                {
                    // 如果和上一条输出的记录的人的名字不同,即代表这是一个新的人的
                    if (isoutput)
                    {
                        // 只有输出过通话记录了才可能要输出总额
                        printf("Total amount: $%.2f\n", amount);
                    }
                    amount = 0;
                    charge = 0;
                    strcpy(lastoutputname, nowoutputingname);
                    printf("%s %02d\n", nowoutputingname, data[i]->m);
                }
                charge = CalcEachCom(temp, data[i], &eachmin);
                printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n",
                    temp->d, temp->h, temp->min, data[i]->d, data[i]->h, data[i]->min,
                    eachmin, charge);
                temp = NULL; // on-line的记录一旦输出了就废掉
                isoutput = 1;
                amount += charge;
            }
        }
    }
    // 如果前面输出过记录,则输出最后一个人的总额
    if (isoutput)
    {
        printf("Total amount: $%.2f\n", amount);
    }
    return;
}

int main()
{
    int i;
    int r;
    for (i = 0; i < 24; i++)
    {
        scanf("%d", &r);
        rate[i] = (double)r / 100;
    }
    scanf("%d", &N);
    Record data[N];
    char status[10];
    for (i = 0; i < N; i++)
    {
        data[i] = (Record)malloc(sizeof(struct RECORD));
        scanf("%s %d:%d:%d:%d", data[i]->name, &data[i]->m, &data[i]->d, &data[i]->h, &data[i]->min);
        scanf("%s", status);
        if (strcmp(status, "on-line") == 0)
        {
            data[i]->status = 0;
        }
        else
        {
            data[i]->status = 1;
        }
    }
    qsort(data, N, sizeof(data[0]), compare);
    OutPut(data);

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值