问题 I: Stones

题目描述

There are N stones arranged in a row. Every stone is painted white or black. A string S represents the color of the stones. The i-th stone from the left is white if the i-th character of S is ., and the stone is black if the character is #.

Takahashi wants to change the colors of some stones to black or white so that there will be no white stone immediately to the right of a black stone. Find the minimum number of stones that needs to be recolored.

Constraints
1≤N≤2×105
S is a string of length
N consisting of . and #.

输入

Input is given from Standard Input in the following format:

N
S

输出

Print the minimum number of stones that needs to be recolored.

样例输入
复制样例数据 3
#.#

样例输出
1

思路:被这题卡了一个小时,是一开始的思路不对,想得太复杂了,还分类讨论,其实只需要暴力算法就可以通过了,就是将一块石头的左边全部变为white,右边全部为black,然后更新一下答案即可

#include <iostream>
#include <string>
#include <map>
#include <cstdio>
#include <algorithm>
using namespace std;

char a[200005];
int black[200005],beginn,endd;
int cntb=1;
int main()
{
    int n,enddd;
    cin>>n;
    getchar();
    int ans=n;
    for(int i=1;i<=n;i++) {scanf("%c",&a[i]);if(a[i]=='#') black[cntb++]=i;}
    cntb--,beginn=black[1],endd=black[cntb];
    //cout<<cntb<<endl;
    int CNT=0;
    for(int i=1;i<=cntb;i++)
    {
        int cnt=i-1;
        int Cnt=0;
        int j;
        for(j=black[i];a[j]=='#';j++) Cnt++;
        i+=Cnt-1;
        CNT+=Cnt;
        int cntw=(n-j+1)-(cntb-CNT);
        //cout<<cntw<<endl;
        ans=min(cntw+cnt,ans);
    }
    ans=min(cntb,ans);
    cout<<ans<<endl;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值