Maximum Multiple

Problem Description

Given an integer n, Chiaki would like to find three positive integers x, y and z such that: n=x+y+z, x∣n, y∣n, z∣n and xyz is maximum.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106).

Output

For each test case, output an integer denoting the maximum xyz. If there no such integers, output −1 instead.

Sample Input

3 1 2 3

Sample Output

-1 -1 1

答案:

#include<stdio.h>
int main()
{
    long long int n, s;
    long long int mmax;
    scanf("%d", &n);
    while (n--)
    {
        mmax = 0;
        scanf("%lld", &s);
        if (s % 12 == 1 || s % 12 == 2 || s % 12 == 5 || s % 12 == 7 || s % 12 == 10 || s % 12 == 11)
            printf("-1\n");//每12个数轮一轮
        else
        {
            if (s % 3 == 0)
                mmax = (s / 3)*(s / 3)*(s / 3);//如果是3的倍数,就是s/3的三次方
            else
                mmax = (s / 4)*(s / 4)*(s / 4) * 2;//其他的就是这个数的四分之一*四分之一*二分之一
            printf("%lld\n", mmax);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值