1002 1002 A + B Problem II大数相加

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 317528    Accepted Submission(s): 61692


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author

Ignatius.L


原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1002


大数相加思路非常简单,只要用数组将大数的每一位都存起来,注意进位。。。。。



AC代码:

#include<stdio.h>
#include<string.h>
#define Max 101
void print(char sum[]);
void bigNumAdd(char a[],char b[],char sum[]);
int main()
{
	char a[Max];
	char b[Max];
	char sum[Max];
	gets(a);
	gets(b);
	bigNumAdd(a,b,sum);
	print(sum);
	return 0;
}

void bigNumAdd(char a[],char b[],char sum[])
{
	int i=0;
	int c=0;//表示进位
          //初始化,对以后位运算有很大帮助!
	char m[Max]={0};
	char n[Max]={0};
	memset(sum,0,Max*sizeof(char)); //这里不能写成memset(sum,0,sizeof(sum));原因见注意事项1
	//字符串反转且字符串变数字
	int lenA=strlen(a);
	int lenB=strlen(b);
	for (i=0;i<lenA;i++)
	{
		m[i]=a[lenA-i-1]-'0';
	}
	for (i=0;i<lenB;i++)
	{
		n[i]=b[lenB-i-1]-'0';
	}
	//位运算
	for (i=0;i<lenA||i<lenB;i++)
	{
		sum[i]=(m[i]+n[i]+c)%10+'0';//得到末位
		c=(m[i]+n[i]+c)/10;//得到进位
	}
}

void print(char sum[])
{
	int i=0;
	int j=0;
	int len = strlen(sum);
	for (i=len-1;sum[i]==0;i--); //找到第一个不为零的位置,方便输出
	for (j=i;j>=0;j--)
	{
		printf("%c",sum[j]);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值