[PAT]1079 Total Sales of Supply Chain (25 分)(样例2、3、5、6未过原因)

一、题意

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K​i​​ ID[1] ID[2] ... ID[K​i​​]

where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. K​j​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10​10​​.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

二、题解

题意:供应链中包含 零售商、 经销商 和 供应商 三种角色。给出供应链和最终零售商的销售数量,计算最终零售商的销售额。在给出的供应链中,经销商与供应商的角色(除了根节点)不是绝对的,而是相对的。除了根节点,非零售商的父节点,即为对应该节点的供应商。这样说可能还是很乱。其实题目就是,给出一棵树,只有叶子节点是零售商,每往下一层,销售价格变为上层的1+r倍,计算零售商所有销售值。

解题思路为:建树->遍历节点,如果是叶节点,计算该叶节点的销售值,加在总和里->输出结果。

样例2、3、5、6未通过原因:代码中不要使用float,要使用double。

三、代码

#include <bits/stdc++.h>

using namespace std;
int N;
double P, r;
struct node {
    vector<node* > children;
    int cnt;
    node() {
        this->cnt = 0;
    }
};
vector<node* > nodes;
double ans = 0.0;

void getAnswer(node* root, int height) {
    if(root->children.size() == 0) {
        //cout<<root->cnt<<" h: "<<height<<endl;
        ans += 1.0*P*pow((1+r), height) * root->cnt;
    } else {
        for(int i=0; i<root->children.size(); i++) {
            getAnswer(root->children[i], height+1);
        }
    }
}
int main() {
    scanf("%d %lf %lf", &N, &P, &r);
    r = r/100;

    nodes.resize(N);
    for(int i=0; i<N; i++){
        node* tempNode = new node();
        nodes[i] = tempNode;
    }

    for(int i=0; i<N; i++) {
        int cnt;
        cin>>cnt;
        if(cnt!=0) {
            for(int j=0; j<cnt; j++) {
                int tempNode;
                scanf("%d", &tempNode);
                nodes[i]->children.push_back(nodes[tempNode]);
            }
        } else {
            int tempCnt;
            scanf("%d", &tempCnt);
            nodes[i]->cnt = tempCnt;
        }
    }
    getAnswer(nodes[0], 0);

    printf("%0.1f\n", ans);

    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值