Trucking (spfa+2分)

A certain local trucking company would like to transport some goods on a cargo truck from one place to another. It is desirable to transport as much goods as possible each trip. Unfortunately, one cannot always use the roads in the shortest route: some roads may have obstacles (e.g. bridge overpass, tunnels) which limit heights of the goods transported. Therefore, the company would like to transport as much as possible each trip, and then choose the shortest route that can be used to transport that amount. 

For the given cargo truck, maximizing the height of the goods transported is equivalent to maximizing the amount of goods transported. For safety reasons, there is a certain height limit for the cargo truck which cannot be exceeded.
Input
The input consists of a number of cases. Each case starts with two integers, separated by a space, on a line. These two integers are the number of cities (C) and the number of roads (R). There are at most 1000 cities, numbered from 1. This is followed by R lines each containing the city numbers of the cities connected by that road, the maximum height allowed on that road, and the length of that road. The maximum height for each road is a positive integer, except that a height of -1 indicates that there is no height limit on that road. The length of each road is a positive integer at most 1000. Every road can be travelled in both directions, and there is at most one road connecting each distinct pair of cities. Finally, the last line of each case consists of the start and end city numbers, as well as the height limit (a positive integer) of the cargo truck. The input terminates when C = R = 0.
Output
For each case, print the case number followed by the maximum height of the cargo truck allowed and the length of the shortest route. Use the format as shown in the sample output. If it is not possible to reach the end city from the start city, print "cannot reach destination" after the case number. Print a blank line between the output of the cases.
Sample Input
5 6
1 2 7 5
1 3 4 2
2 4 -1 10
2 5 2 4
3 4 10 1
4 5 8 5
1 5 10
5 6
1 2 7 5
1 3 4 2
2 4 -1 10
2 5 2 4
3 4 10 1
4 5 8 5
1 5 4
3 1
1 2 -1 100
1 3 10
0 0

Sample Output

Case 1:
maximum height = 7
length of shortest route = 20

Case 2:
maximum height = 4
length of shortest route = 8
Case 3:
cannot reach destination

思路: 这个题其实挺难的,他有两个条件,一个是车有多高,还一个就是最短路,其中车的装载高度是第一位的,因此,首先一个很自然的想法应该是,从他给的车的最大高度逐渐向下枚举,直到找到一个存在最短路的高度就行了,这样在时间上肯定不太可行,所以很自然就转到二分了。

#include<cstdio>
#include<cstring>
#include<map>
#include<cmath>
#include<algorithm>
#include<string>
#include<iostream>
#include<queue>
using namespace std;
const int inf = 0x3f3f3f3f;
int n,m;
int limit[1100][1100];
int dist[1100][1100];
int inq[200100];
int dis[200100];
int spfa(int be,int ed,int h)
{
    memset(inq,0,sizeof(inq));
    memset(dis,inf,sizeof(dis));
    dis[be] = 0;
    queue <int> q;
    q.push(be);
    while(!q.empty())
    {
        int tmp = q.front();
        q.pop();
        inq[tmp] = 0;
        for(int i = 1; i <= n; i++)
        {
            if(limit[tmp][i] < h && limit[tmp][i] != -1) continue;
            if(dist[tmp][i] + dis[tmp] < dis[i])
            {
                dis[i] = dis[tmp] + dist[tmp][i];
                if(!inq[i]) q.push(i);
            }
        }
    }
    if(dis[ed] == inf) return 0;
    else return dis[ed];
}
int main()
{
     int index = 1;
     while(scanf("%d%d",&n,&m)&&m+n)
     {
         memset(limit,-1,sizeof(limit));
         memset(dist,inf,sizeof(dist));
         for(int i = 0; i < m; i++)
         {
             int x,y,l,d;
             scanf("%d%d%d%d",&x,&y,&l,&d);
             if(limit[x][y] < l) limit[x][y] = limit[y][x] = l;
             if(dist[x][y] > d) dist[x][y] = dist[y][x] = d;
         }
         int be,ed,load;
         scanf("%d%d%d",&be,&ed,&load);
         int l = 0, r = load;
         while(l <= r)
         {
             int mid = (l+r) / 2;
             if(spfa(be,ed,mid)==0) r = mid - 1;
             else l = mid + 1;
         }
         l--;
         int ans = spfa(be,ed,l);
         if(index != 1) printf("\n");
         printf("Case %d:\n",index++);
         if(l <= 0) printf("cannot reach destination\n");
         else printf("maximum height = %d\nlength of shortest route = %d\n",l,ans);
     }
     return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值