HDU - 2962 Trucking 最短路加二分

HDU - 2962 Trucking

A certain local trucking company would like to transport some goods on a cargo truck from one place to another. It is desirable to transport as much goods as possible each trip. Unfortunately, one cannot always use the roads in the shortest route: some roads may have obstacles (e.g. bridge overpass, tunnels) which limit heights of the goods transported. Therefore, the company would like to transport as much as possible each trip, and then choose the shortest route that can be used to transport that amount.

For the given cargo truck, maximizing the height of the goods transported is equivalent to maximizing the amount of goods transported. For safety reasons, there is a certain height limit for the cargo truck which cannot be exceeded.

Input
The input consists of a number of cases. Each case starts with two integers, separated by a space, on a line. These two integers are the number of cities (C) and the number of roads (R). There are at most 1000 cities, numbered from 1. This is followed by R lines each containing the city numbers of the cities connected by that road, the maximum height allowed on that road, and the length of that road. The maximum height for each road is a positive integer, except that a height of -1 indicates that there is no height limit on that road. The length of each road is a positive integer at most 1000. Every road can be travelled in both directions, and there is at most one road connecting each distinct pair of cities. Finally, the last line of each case consists of the start and end city numbers, as well as the height limit (a positive integer) of the cargo truck. The input terminates when C = R = 0.

Output
For each case, print the case number followed by the maximum height of the cargo truck allowed and the length of the shortest route. Use the format as shown in the sample output. If it is not possible to reach the end city from the start city, print "cannot reach destination" after the case number. Print a blank line between the output of the cases.

Sample Input
5 6
1 2 7 5
1 3 4 2
2 4 -1 10
2 5 2 4
3 4 10 1
4 5 8 5
1 5 10
5 6
1 2 7 5
1 3 4 2
2 4 -1 10
2 5 2 4
3 4 10 1
4 5 8 5
1 5 4
3 1
1 2 -1 100
1 3 10
0 0
Sample Output
Case 1:
maximum height = 7
length of shortest route = 20

Case 2:
maximum height = 4
length of shortest route = 8

Case 3:
cannot reach destination

题意货车拉货,拉的货越多越好,但是车有货的重量上限,每条路也有货的重量上限,在货拉的多的前提下,求最短路程。
一开始我不知如何平衡路的路程和货物上限这两个权值,看了题解才知道用二分,这还是我第一次用到二分,还是做得题少啊
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=1010;
int C,R;
struct edge{
	int v,w,next,h;
}e[maxn*maxn];
int head[maxn],dis[maxn],cnt;
bool vis[maxn];
void add_edge(int u,int v,int h,int w)
{
	e[cnt].v=v;
	e[cnt].w=w;
	e[cnt].h=h;
	e[cnt].next=head[u];
	head[u]=cnt++;
}
void spfa(int s,int limit)
{
    for(int i=1;i<=C;i++)
    {
    	dis[i]=INF;
    	vis[i]=false;
    }
	
	dis[s]=0;
	vis[s]=true;
	queue<int> q;
	q.push(s);
	
	while(!q.empty())
	{
		int temp=q.front();
		q.pop();
		vis[temp]=false;
		
		for(int i=head[temp];i!=-1;i=e[i].next)
		{
			//printf("%d\n",e[i].h);
			if(e[i].h<limit) continue;
			int to=e[i].v;
			if(dis[to]>dis[temp]+e[i].w)
			{
				dis[to]=dis[temp]+e[i].w;
				if(!vis[to])
				{
					vis[to]=true;
					q.push(to);
				}
			}
		}
	}
}
int main(void)
{
	int u,v,w,h;
	int s,t;
	int limit;
	int count=0;
	while(scanf("%d%d",&C,&R)!=EOF&&C!=0&&R!=0)
	{
		cnt=0;
		memset(head,-1,sizeof(head));
		for(int i=1;i<=R;i++)
		{
			scanf("%d%d%d%d",&u,&v,&h,&w);
			if(h==-1) h=INF;
			add_edge(u,v,h,w);
			add_edge(v,u,h,w);
		}
		scanf("%d%d%d",&s,&t,&limit);
		int l=0,r=limit,ans=INF,mid,h;
		while(l<=r)
	    {
	    	mid=(l+r)/2;
	    	spfa(s,mid); 
	    	if(dis[t]!=INF)
	    	{
	    		l=mid+1;
	    		ans=dis[t];
	    		h=mid;
	    	}
	    	else
	    	    r=mid-1;   
	    }
	    if(count) printf("\n");
		printf("Case %d:\n",++count);
		if(ans!=INF)
		{
			printf("maximum height = %d\n",h);
			printf("length of shortest route = %d\n",ans);
		}
		else{
			printf("cannot reach destination\n");
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值