Trucking(HDU 2962)---二分枚举最短路

题目链接

题目描述

A certain local trucking company would like to transport some goods on a cargo truck from one place to another. It is desirable to transport as much goods as possible each trip. Unfortunately, one cannot always use the roads in the shortest route: some roads may have obstacles (e.g. bridge overpass, tunnels) which limit heights of the goods transported. Therefore, the company would like to transport as much as possible each trip, and then choose the shortest route that can be used to transport that amount.
For the given cargo truck, maximizing the height of the goods transported is equivalent to maximizing the amount of goods transported. For safety reasons, there is a certain height limit for the cargo truck which cannot be exceeded.

输入格式

The input consists of a number of cases. Each case starts with two integers, separated by a space, on a line. These two integers are the number of cities © and the number of roads ®. There are at most 1000 cities, numbered from 1. This is followed by R lines each containing the city numbers of the cities connected by that road, the maximum height allowed on that road, and the length of that road. The maximum height for each road is a positive integer, except that a height of -1 indicates that there is no height limit on that road. The length of each road is a positive integer at most 1000. Every road can be travelled in both directions, and there is at most one road connecting each distinct pair of cities. Finally, the last line of each case consists of the start and end city numbers, as well as the height limit (a positive integer) of the cargo truck. The input terminates when C = R = 0.

输出格式

For each case, print the case number followed by the maximum height of the cargo truck allowed and the length of the shortest route. Use the format as shown in the sample output. If it is not possible to reach the end city from the start city, print “cannot reach destination” after the case number. Print a blank line between the output of the cases.

输入样例

5 6
1 2 7 5
1 3 4 2
2 4 -1 10
2 5 2 4
3 4 10 1
4 5 8 5
1 5 10
0 0

输出样例

Case 1:
maximum height = 7
length of shortest route = 20

分析

题目大意是有n个城市和m条路线,每条路线都有限定货车运载货物所能通过最大高度,求从s城市到t城市能运载最大高度的最短路。
本题主要是通过二分思想,二分枚举当前货车运载的高度然后求最短路找到最大高度即可,具体看源码。
以下是分别用dijkstra、SPFA和SPFA(SLF优化)算法写成的源码。

源程序

Dijkstra算法

#include <bits/stdc++.h>
#define MAXN 1005
#define INF 0x3f3f3f3f
using namespace std;
struct Edge{	//链式前向星 
	int v,w,h,next;
	Edge(){};
	Edge(int _v,int _w,int _h,int _next){
		v=_v,w=_w,h=_h,next=_next; 
	};
	bool operator <(const Edge a)const{
		return w>a.w;
	};
}edge[MAXN*MAXN];
int EdgeCount,head[MAXN];
int n,m,s,t,h,dis[MAXN];
bool used[MAXN];
void addEdge(int u,int v,int w,int h)	//链式前向星建图 
{
	edge[++EdgeCount]=Edge(v,w,h,head[u]);
	head[u]=EdgeCount;
}
void dijkstra(int now)
{
	priority_queue<Edge> q;
	memset(dis,0x3f,sizeof(dis));
	memset(used,false,sizeof(used));
	dis[s]=0;
	q.push(Edge{s,0,0,0});
	while(!q.empty()){
		int u=q.top().v;q.pop();
		if(used[u])continue;
		used[u]=true;
		for(int i=head[u];i;i=edge[i].next){
			int v=edge[i].v,w=edge[i].w,height=edge[i].h;
			if(now>height)continue;	//当前货车高度超过道路限定高度
			if(dis[v]>dis[u]+w){
				dis[v]=dis[u]+w;
				q.push(Edge{v,dis[v],0,0});
			} 
		}
	}
}
int main()
{
	int cnt=0,flag=false;	//测试数、空行控制 
	while(scanf("%d%d",&n,&m)&&(n||m)){
		memset(head,0,sizeof(head));	//初始化 
		EdgeCount=0;
		for(int i=1;i<=m;i++){	//建图 
			int u,v,w,h;
			scanf("%d%d%d%d",&u,&v,&h,&w);
			if(h==-1)h=INF;		//无限高 
			addEdge(u,v,w,h);
			addEdge(v,u,w,h);
		}
		scanf("%d%d%d",&s,&t,&h);	//起点、终点、限制高度 
		int l=0,r=h+1,ans1=-INF,ans2=INF;
		while(l<r){	//枚举货车运载货物高度 
			int mid=(l+r)>>1;
			dijkstra(mid);
			if(dis[t]==INF)r=mid;
			else{
				l=mid+1;
				ans1=mid;
				ans2=dis[t]; 
			}
		} 
		if(flag)printf("\n");	//输出空行 
		else flag=true;
		printf("Case %d:\n",++cnt);
		if(ans1==-INF&&ans2==INF)printf("cannot reach destination\n");
		else{ 
			printf("maximum height = %d\n",ans1);
			printf("length of shortest route = %d\n",ans2);
		}
	}
} 

SPFA算法

#include <bits/stdc++.h>
#define MAXN 1005
#define INF 0x3f3f3f3f
using namespace std;
struct Edge{	//链式前向星 
	int v,w,h,next;
	Edge(){};
	Edge(int _v,int _w,int _h,int _next){
		v=_v,w=_w,h=_h,next=_next; 
	};
}edge[MAXN*MAXN];
int EdgeCount,head[MAXN];
int n,m,s,t,h,dis[MAXN],ven[MAXN];
void addEdge(int u,int v,int w,int h)	//链式前向星建图 
{
	edge[++EdgeCount]=Edge(v,w,h,head[u]);
	head[u]=EdgeCount;
}
void SPFA(int now)
{
	queue<int> q;
	memset(dis,0x3f,sizeof(dis));
	memset(ven,0,sizeof(ven));
	dis[s]=0;
	ven[s]=1;
	q.push(s);
	while(!q.empty()){
		int u=q.front();q.pop();
		ven[u]=0;
		for(int i=head[u];i;i=edge[i].next){
			int v=edge[i].v,w=edge[i].w,height=edge[i].h;
			if(now>height)continue;	//当前货车高度超过道路限定高度
			if(dis[v]>dis[u]+w){
				dis[v]=dis[u]+w;
				if(!ven[v]){
					q.push(v);
					ven[v]=1;
				}
			} 
		}
	}
}
int main()
{
	int cnt=0,flag=false;	//测试数、空行控制 
	while(scanf("%d%d",&n,&m)&&(n||m)){
		memset(head,0,sizeof(head));	//初始化 
		EdgeCount=0;
		for(int i=1;i<=m;i++){	//建图 
			int u,v,w,h;
			scanf("%d%d%d%d",&u,&v,&h,&w);
			if(h==-1)h=INF;		//无限高 
			addEdge(u,v,w,h);
			addEdge(v,u,w,h);
		}
		scanf("%d%d%d",&s,&t,&h);	//起点、终点、限制高度 
		int l=0,r=h+1,ans1=-INF,ans2=INF;
		while(l<r){	//枚举货车运载货物高度 
			int mid=(l+r)>>1;
			SPFA(mid);
			if(dis[t]==INF)r=mid;
			else{
				l=mid+1;
				ans1=mid;
				ans2=dis[t]; 
			}
		} 
		if(flag)printf("\n");	//输出空行 
		else flag=true;
		printf("Case %d:\n",++cnt);
		if(ans1==-INF&&ans2==INF)printf("cannot reach destination\n");
		else{ 
			printf("maximum height = %d\n",ans1);
			printf("length of shortest route = %d\n",ans2);
		}
	}
} 

SPFA算法之SLF优化

#include <bits/stdc++.h>
#define MAXN 1005
#define INF 0x3f3f3f3f
using namespace std;
struct Edge{	//链式前向星 
	int v,w,h,next;
	Edge(){};
	Edge(int _v,int _w,int _h,int _next){
		v=_v,w=_w,h=_h,next=_next; 
	};
}edge[MAXN*MAXN];
int EdgeCount,head[MAXN];
int n,m,s,t,h,dis[MAXN],ven[MAXN];
void addEdge(int u,int v,int w,int h)	//链式前向星建图 
{
	edge[++EdgeCount]=Edge(v,w,h,head[u]);
	head[u]=EdgeCount;
}
void SPFA(int now)
{
	deque<int> q;
	memset(dis,0x3f,sizeof(dis));
	memset(ven,0,sizeof(ven));
	dis[s]=0;
	ven[s]=1;
	q.push_back(s);
	int k;
	while(k=q.size()){
		int u=q.front();q.pop_front();
		ven[u]=0;
		for(int i=head[u];i;i=edge[i].next){
			int v=edge[i].v,w=edge[i].w,height=edge[i].h;
			if(now>height)continue;	//当前货车高度超过道路限定高度
			if(dis[v]>dis[u]+w){
				dis[v]=dis[u]+w;
				if(!ven[v]){
					if(k>1&&dis[v]>dis[q.front()])q.push_front(v);
					else q.push_back(v);
					ven[v]=1;
				}
			} 
		}
	}
}
int main()
{
	int cnt=0,flag=false;	//测试数、空行控制 
	while(scanf("%d%d",&n,&m)&&(n||m)){
		memset(head,0,sizeof(head));	//初始化 
		EdgeCount=0;
		for(int i=1;i<=m;i++){	//建图 
			int u,v,w,h;
			scanf("%d%d%d%d",&u,&v,&h,&w);
			if(h==-1)h=INF;		//无限高 
			addEdge(u,v,w,h);
			addEdge(v,u,w,h);
		}
		scanf("%d%d%d",&s,&t,&h);	//起点、终点、限制高度 
		int l=0,r=h+1,ans1=-INF,ans2=INF;
		while(l<r){	//枚举货车运载货物高度 
			int mid=(l+r)>>1;
			SPFA(mid);
			if(dis[t]==INF)r=mid;
			else{
				l=mid+1;
				ans1=mid;
				ans2=dis[t]; 
			}
		} 
		if(flag)printf("\n");	//输出空行 
		else flag=true;
		printf("Case %d:\n",++cnt);
		if(ans1==-INF&&ans2==INF)printf("cannot reach destination\n");
		else{ 
			printf("maximum height = %d\n",ans1);
			printf("length of shortest route = %d\n",ans2);
		}
	}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值