HDU2962--Trucking最短路

Description

A certain local trucking company would like to transport some goods on a cargo truck from one place to another. It is desirable to transport as much goods as possible each trip. Unfortunately, one cannot always use the roads in the shortest route: some roads may have obstacles (e.g. bridge overpass, tunnels) which limit heights of the goods transported. Therefore, the company would like to transport as much as possible each trip, and then choose the shortest route that can be used to transport that amount.

For the given cargo truck, maximizing the height of the goods transported is equivalent to maximizing the amount of goods transported. For safety reasons, there is a certain height limit for the cargo truck which cannot be exceeded.
 

Input

The input consists of a number of cases. Each case starts with two integers, separated by a space, on a line. These two integers are the number of cities (C) and the number of roads (R). There are at most 1000 cities, numbered from 1. This is followed by R lines each containing the city numbers of the cities connected by that road, the maximum height allowed on that road, and the length of that road. The maximum height for each road is a positive integer, except that a height of -1 indicates that there is no height limit on that road. The length of each road is a positive integer at most 1000. Every road can be travelled in both directions, and there is at most one road connecting each distinct pair of cities. Finally, the last line of each case consists of the start and end city numbers, as well as the height limit (a positive integer) of the cargo truck. The input terminates when C = R = 0.
 

Output

For each case, print the case number followed by the maximum height of the cargo truck allowed and the length of the shortest route. Use the format as shown in the sample output. If it is not possible to reach the end city from the start city, print "cannot reach destination" after the case number. Print a blank line between the output of the cases.
 

Sample Input

    
    
5 6 1 2 7 5 1 3 4 2 2 4 -1 10 2 5 2 4 3 4 10 1 4 5 8 5 1 5 10 5 6 1 2 7 5 1 3 4 2 2 4 -1 10 2 5 2 4 3 4 10 1 4 5 8 5 1 5 4 3 1 1 2 -1 100 1 3 10 0 0
 

Sample Output

    
    
Case 1: maximum height = 7 length of shortest route = 20 Case 2: maximum height = 4 length of shortest route = 8 Case 3: cannot reach destination
 
#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
using namespace std;
#define maxn 1008
#define inf 0x7fffffff
vector <int> ans[maxn];//用来存能走的路
vector <int> dis[maxn];//用来存能走的路的距离
vector <int> hei[maxn];//用来存能走的路的高度
int High[maxn];//用来存到每个点的最大高度
int leastlen[maxn];//用来存到每个点的最短距离,当然是建立在最大高度下的最短距离
inline int min(int a,int b,int c)
{
	if(a>b)a=b;
	if(a>c)a=c;
	return a;
}
int main()
{
	int c,r,time=0;
	while((scanf("%d%d",&c,&r)==2)&&(r||c))
	{
		time++;
		queue <int> q;
		for(int i=1;i<=c;i++)
		{
			High[i]=-inf;
			leastlen[i]=inf;
		}
		for(int i=1;i<=c;i++)
		{
			ans[i].clear();
			dis[i].clear();
			hei[i].clear();
		}
		int a,b,high,len;
		for(int i=1;i<=r;i++)//这里等下考虑用不用双向
		{
			scanf("%d%d%d%d",&a,&b,&high,&len);
			ans[a].push_back(b);
			ans[b].push_back(a);
			dis[a].push_back(len);
			dis[b].push_back(len);
			if(high==-1)
			{
				hei[a].push_back(inf);
				hei[b].push_back(inf);
			}
			else 
			{
				hei[a].push_back(high);
				hei[b].push_back(high);
			}
		}
		int s,t,limit;
		scanf("%d%d%d",&s,&t,&limit);//所有的高度应该先和卡车的高度取小
		High[s]=inf;
		leastlen[s]=0;
		q.push(s);
		while(!q.empty())
		{
			int p=q.front();
			q.pop();
			for(int i=0;i<ans[p].size();i++)
			{
				if(min(High[p],hei[p][i],limit)>High[ans[p][i]])//这条路走不走,如果高度有变大,走;
				{
					q.push(ans[p][i]);
					High[ans[p][i]]=min(High[p],hei[p][i],limit);
					leastlen[ans[p][i]]=leastlen[p]+dis[p][i];
				}
				else if(min(High[p],hei[p][i],limit)==High[ans[p][i]])//如果高度不变,但是长度减小,走;
				{
					if(leastlen[p]+dis[p][i]<leastlen[ans[p][i]])
					{
						q.push(ans[p][i]);
						leastlen[ans[p][i]]=leastlen[p]+dis[p][i];
					}
				}

			}
		}//这样的做法忽略了高度变小,长度变小这种可能有利的情况
		if(leastlen[t]!=inf)//距离可能还可以优化
		{
			queue <int> q;
			High[s]=inf;
			q.push(s);
			int maxhight=High[t];
			while(!q.empty())
			{
				int p=q.front();
				q.pop();
				for(int i=0;i<ans[p].size();i++)
				{
					if((min(High[p],hei[p][i],limit)>=maxhight)&&(leastlen[p]+dis[p][i]<=leastlen[ans[p][i]]))
					{
						q.push(ans[p][i]);
						leastlen[ans[p][i]]=leastlen[p]+dis[p][i];
					}
				}
			}
		}
		printf("Case %d:\n",time);
		if(leastlen[t]==inf)
		{
			printf("cannot reach destination\n");
		}
		else 
		{
			printf("maximum height = %d\n",High[t]==inf?limit:High[t]);
			printf("length of shortest route = %d\n",leastlen[t]);
		}
	}
	return 0;
}
		

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值