Course Selection System ZOJ - 3956 (0,1背包变型)

There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selectsm courses x1x2, ..., xm, then his comfort level of the semester can be defined as follows:

$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$

Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.

Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci≤ 100).

It is guaranteed that the sum of all n does not exceed 5000.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input
2
3
10 1
5 1
2 10
2
1 10
2 10
Sample Output
191
0
Hint

For the first case, Edward should select the first and second courses.

For the second case, Edward should select no courses.


思路 :


这个题的公式涉及两个变量,令 x = sum(Hi),y = sum(Ci) 就是求 f = x^2 - x*y - y^2 的最大值,如果把y当做常熟对称轴就是 x = y/2 显然如果 x < y ,则 f < 0,所以x越大越好。即,在某一个y下,它构成的x越大越好。因此就可以这样考虑了,每个课程,挑或者不挑,使得所有可能的y得到的x最大,这就转化成背包问题。只不过这个背包是个必须要装满的背包罢了。


#include <cstdio>
#include <map>
#include <algorithm>
#include <cmath>
#include <iostream>
#include <cstring>
using namespace std;
typedef long long ll;

int x[100000];
int y[100000];
ll dp[100000];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        memset(dp,0,sizeof(dp));
        scanf("%d",&n);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d%d",&x[i],&y[i]);
        }
        for(int i = 1; i <= n; i++)
        {
            for(int j = 101*n; j >= y[i]; j--)
            {
                if(dp[j-y[i]] || j == y[i])
                {
                    dp[j] = max(dp[j-y[i]] + x[i],dp[j]);
                }
            }
        }
        ll max_ = 0;
        for(int i = 0; i <= n*101; i++)
        {
            if(dp[i]) max_ = max(max_,dp[i]*dp[i] - dp[i]*i - i*i);
        }
        printf("%lld\n",max_);
    }
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值