POJ 3273-Monthly Expense(二分求最小和中的最大)

Problem B

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 19   Accepted Submission(s) : 5
Problem Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

 

Input
Line 1: Two space-separated integers: <i>N</i> and <i>M</i><br>Lines 2..<i>N</i>+1: Line <i>i</i>+1 contains the number of dollars Farmer John spends on the <i>i</i>th day
 

Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
 

Sample Input
 
 
7 5100400300100500101400
 

Sample Output
 
 
500
 
题意: 给出农夫在n天中每天的花费,要求把这n天分作m组,每组的天数必然是连续的,要求分得各组的花费之和应该尽可能地小,最后输出各组花费之和中的最大值。

#include<iostream>
#include<algorithm>
using namespace std;
int n, m, a[100010], low, high, mid;
int judge(int mid1)
{
	int sum = 0, ans = 1;//开始为整体为一组
	for (int i = 1; i <= n; i++)
	{
		if (sum + a[i] <= mid1)
			sum += a[i];
		else
		{
			sum = a[i];
			ans++;
		}
	}
	if (ans > m)
		return 1;//组数偏多mid偏小low=mid+1
	else
		return 0;//组数偏少mid偏大
}
int main()
{
	cin >> n >> m;
	for (int i = 1; i <= n; i++)
	{
		cin >> a[i];
		low = max(a[i], low);
		high += a[i];
	}
	while (low <= high)
	{
		mid = (low + high) / 2;
		if (judge(mid))//
			low = mid + 1;
		else
			high = mid - 1;
			
	}
	cout << mid << endl;
	return 0;
}



		



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

不会敲代码的小帅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值