SDUT 2676 3-7 类的友元函数的应用

题目描述

通过本题目的练习可以掌握类的友元函数的定义和用法
要求设计一个点类Point,它具有两个double型的数据成员x,y。为该类设计构造函数。并为其添加一个友元函数用于计算并输出两点间的距离;再添加一个输出成员函数用于输出点的信息。
 
 
并编写主函数,实现以下的输入输出内容。

输入

4double型的数,中间用一个空格间隔。

输出

输出数据共3行,前两行用于显示要求距离的两个点的信息,第三行显示两点的距离。

示例输入

5 6 2 3

示例输出

The first point is the coordinate:X=5,Y=6
The second point is the coordinate:X=2,Y=3
The distance between the two points is:4.24264
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;

class Point
{
private:
    double x,y,x1,y1;
public:
    Point(double a1,double b1,double c1,double d1)
    {
        x=a1;
        y=b1;
        x1=c1;
        y1=d1;
        cout<<"The first point is the coordinate:X="<<x<<",Y="<<y<<endl;
        cout<<"The second point is the coordinate:X="<<x1<<",Y="<<y1<<endl;
    }
    friend void display(Point &);//定义友元函数
};
void display(Point &q)
{
    double sum=sqrt((q.x-q.x1)*(q.x-q.x1)+(q.y-q.y1)*(q.y-q.y1));
    cout<<"The distance between the two points is:"<<sum<<endl;

}
int main()
{
    double a,b,c,d;
    cin>>a>>b>>c>>d;
    Point q1(a,b,c,d);
    display(q1);

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值