【poj3461】Oulipo 【BAPC 2006 Qualification】

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

这道题标解是KMP,但是用hash就可以过,下面是程序:

#include<stdio.h>
#include<string.h>
#include<iostream>
#define ll unsigned long long 
using namespace std;
ll hash[1000005],x,cf[1000005];
char a[1000005];
void read(ll &s,int &l){
	s=l=0;
	char c=getchar();
	while(!(c>='A'&&c<='Z')){
		c=getchar();
	}
	while(c>='A'&&c<='Z'){
		l++;
		s*=27;
		s+=c-'A'+1;
		c=getchar();
	}
}
ll ask(int i,int j){
	return hash[j]-hash[i-1]*cf[j-i+1];
}
void work(){
	int i,l1,l2,s=0;
	read(x,l1);
	scanf("%s",a+1);
	l2=strlen(a+1);
	hash[1]=a[1]-'A'+1;
	for(i=2;i<=l2;i++){
		hash[i]=hash[i-1]*27+a[i]-'A'+1;
	}
	for(i=1;i<=l2-l1+1;i++){
		if(ask(i,i+l1-1)==x){
			s++;
		}
	}
	printf("%d\n",s);
}
int main(){
	int t,i;
	for(cf[0]=1,i=1;i<=1000000;i++){
		cf[i]=cf[i-1]*27;
	}
	scanf("%d",&t);
	while(t--){
		work();
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值