BFS - Catch That Cow(并列进行)

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. 

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute 
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute. 

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4


        
  
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
        
 

题意:给出农夫的位置(在x轴上),和牛的位置。农夫有3种走法(x-1  or  x+1 or  x*2),问最短移动次数。

思路:并列进行BFS。(注意范围)


#include<bits/stdc++.h>
using namespace std;
int mark[200001];
int cnt;
void bfs(int n,int k)
{
    queue<int>q;
    q.push(n); //一种状态
    q.push(cnt); //每一种状态后跟着一个当前所用的次数
    mark[n]=1; //标记
    while(!q.empty())
    {
        n=q.front();
        q.pop();
        cnt=q.front();
        q.pop();
        if(n==k)
        {
            return;
        }
        if(n-1>=0&&!mark[n-1]) //当前选择的三种之一,并列进行
        {
            q.push(n-1);
            q.push(cnt+1);
            mark[n-1]=1;
        }
        if(n+1<200001&&!mark[n+1]) //当前选择的三种之一,并列进行
        {
            q.push(n+1);
            q.push(cnt+1);
            mark[n+1]=1;
        }
        if(n*2<200001&&!mark[n*2]) //当前选择的三种之一,并列进行
        {
             q.push(n*2);
            q.push(cnt+1);
            mark[n*2]=1;
        }

    }
}
int main()
{
    int n,k;
    while(~scanf("%d%d",&n,&k))
  {
    if(n>=k)
    {
        printf("%d\n",n-k);
        continue;
    }
    cnt=0;
    memset(mark,0,sizeof(mark)); //注意初始化
    bfs(n,k);
    printf("%d\n",cnt);
  }
  return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值