2021/5/20 upc-Contest2814-2021个人训练赛第9场(补题场)

C: Error Correction

题目描述
A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here’s a 4 × 4 matrix which has the parity property:
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2.
Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt.
输入
The input file will contain one or more test cases. The first line of each test case contains one integer n (n < 100), representing the size of the matrix. On the next n lines, there will be n integers per line.
No other integers than ‘0’ and ‘1’ will occur in the matrix. Input will be terminated by a value of 0 for n.
输出
For each matrix in the input file, print one line. If the matrix already has the parity property, print ‘OK’. If the parity property can be established by changing one bit, print ‘Change bit (i,j)’ where i is the row and j the column of the bit to be changed. Otherwise, print ‘Corrupt’.
样例输入 Copy
4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0
样例输出 Copy
OK
Change bit (2,3)
Corrupt

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int main()
{
	int n;
	while(1)
	{
		scanf("%d",&n);
		if(n==0) break;
		int q[n][n];
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<n;j++)
			    scanf("%d",&q[i][j]);
		}
		int a=0,b=0,ai,bi;
		for(int i=0;i<n;i++)
		{
			int s=0;
			for(int j=0;j<n;j++)
			    s+=q[i][j];
			if(s%2==1)
			{
				a++;ai=i+1;
			}
		}
		for(int i=0;i<n;i++)
		{
			int s=0;
			for(int j=0;j<n;j++)
			    s+=q[j][i];
			if(s%2==1)
			{
				b++;bi=i+1;
			}
		}
		if(a==0&&b==0) printf("OK\n");
		else if(a==1&&b==1) printf("Change bit (%d,%d)\n",ai,bi);
		else printf("Corrupt\n");
	}
	return 0;
} 

F: Antiarithmetic

题目描述
A permutation of n is a bijective function of the initial n natural numbers: 0, 1, . . . , n − 1. A permutation p is called antiarithmetic if there is no subsequence of it forming an arithmetic progression of length bigger than 2, i.e. there are no three indices 0 ≤ i < j < k < n such that (pi, pj, pk) forms an arithmetic progression.
For example, the sequence (2, 0, 1, 4, 3) is an antiarithmetic permutation of 5. The sequence (0,5, 4, 3, 1, 2) is not an antiarithmetic permutation as its first, fifth and sixth term (0, 1, 2) forman arithmetic progression; and so do its second, forth and fifth term (5, 3, 1).
Your task is to check whether a given permutation of n is antiarithmetic.
输入
There are several test cases, followed by a line containing 0. Each test case is a line of the input file containing a natural number 3 ≤ n ≤ 10000 followed by a colon and then followed by n distinct numbers separated by whitespace. All n numbers are natural numbers smaller than n.
输出
For each test case output one line with ‘yes’ or ‘no’ stating whether the permutation is antiarithmetic or not.
样例输入 Copy
3: 0 2 1
5: 2 0 1 3 4
6: 2 4 3 5 0 1
0
样例输出 Copy
yes
no
yes

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
using namespace std;
int main()
{
	int n;
	while(1)
	{
		scanf("%d",&n);
		if(n==0) break;
		getchar();
		int q[n],p[n];
		for(int i=0;i<n;i++)
		{
			scanf("%d",&q[i]);p[q[i]]=i;
		}
		int f=0;
		for(int i=0;i<n;i++)
		{
			for(int j=i+1;j<n;j++)
			{
				int k=(q[j]<<1)-q[i];
				if(k<0||k>=n) continue;
				if(p[k]>j)
				{
					f=1;break;
				}
			}
			if(f==1) break;
		}
		if(f==1) printf("no\n");
		else printf("yes\n");
	}
	return 0;
}

K: 立方

题目描述
今年乐乐开始学编程了,上几天刚刚解决了一个平方数的问题,问题是这样的:随便告诉你一个不超过 1 个亿的正整数,请你算出不超过该数的所有立方数的个数。
但是,如果这个超过 1 亿,是一个 18 位正整数,或 28 位的正整数呢?
乐乐不会算,你会吗?
输入
只有一行且只有一个正整数:n
输出
只有一行且只有一个正整数:不超过 n 的平方数个数
样例输入 Copy
100
样例输出 Copy
4
提示
111 = 1 222 = 8
333 = 27 444 = 64
555 = 125 但是 125 > 100
对于 30%的数据, 1 <= n <= 10^8
对于 70%的数据, 1 <= n <= 10^18
对于 100%的数据, 1 <= n <= 10^28

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

int main()
{
	std::ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    double n;
	cin>>n;
	double x=pow(n*1.0,1.0/3.0);
	cout<<(int)x;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值