4.9 矩阵(数组应用的典型范例3)

zoj 1949

Error Correction

A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here's a 4 x 4 matrix which has the parity property:

1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1

The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2.

Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt.


Input

The input will contain one or more test cases. The first line of each test case contains one integer n (n < 100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.


Output

For each matrix in the input file, print one line. If the matrix already has the parity property, print "OK". If the parity property can be established by changing one bit, print "Change bit (i,j)" where i is the row and j the column of the bit to be changed. Otherwise, print "Corrupt".


Sample Input

4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0


Sample Output

OK
Change bit (2,3)

Corrupt


#include <stdio.h>
int main(){

    int num=0;
    scanf("%d",&num);
    while(num!=0){
 int tag[100][100]={0};
    int i=0,j=0;
    for(i=0;i<num;i++){
        for(j=0;j<num;j++){
            scanf("%d",&tag[i][j]);
        }
        getchar();

    }

    int row[100]={0},column[100]={0};
    int row1=0,column1=0;

    for(i=0;i<num;i++){
            int sum=0;
        for(j=0;j<num;j++){
            sum+=tag[i][j];
        }
        if(sum%2==0){
            row[i]=0;
        }else{
            row[i]=1;
        }
        row1+=row[i];


    }

    for(j=0;j<num;j++){
        int sum=0;
        for(i=0;i<num;i++){
            sum+=tag[i][j];
        }
        if(sum%2==0){
            column[j]=0;
        }else{
            column[j]=1;
        }
        column1+=column[j];


    }

    if(row1==0&&column1==0){
        printf("OK\n");
    }else if(row1==1&&column1==1){
        int m,n;
        for(i=0;i<num;i++){
            if(row[i]==1){
                m=i;
                break;
            }
        }
        for(i=0;i<num;i++){
            if(column[i]==1){
                n=i;
                break;
            }
        }
        printf("Change bit (%d,%d)\n",m+1,n+1);
    }else {
        printf("Corrupt\n");
    }

    scanf("%d",&num);
    }


    return 0;


}

两个方面:==等于与=号赋值..竟然还用错..


输出格式bit 与 ()之间有空格 没有空格一直错..

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
4.9 Dotfuscator是一款专业的.NET应用程序混淆器,旨在保护.NET应用程序免受逆向工程和恶意攻击。它可以通过混淆和加密源代码以及重命名和删除不必要的元数据来提高应用程序的安全性。通过对程序进行混淆,开发人员可以使逆向工程师极难理解和分析源代码,从而保护知识产权和商业机密。 Dotfuscator 4.9具有许多功能和优势。首先,它使用先进的混淆算法,可以显著增加应用程序的复杂性,使攻击者难以解析和窃取代码逻辑。其次,它还可以在混淆过程中删除不必要的元数据,从而减小程序的大小并提高性能。此外,它还支持对应用程序进行动态调试保护,以防止调试器附加和动态注入。此功能可以有效防范逆向工程和调试技术。 除了安全性和性能方面的改进外,Dotfuscator 4.9还提供了一些其他的功能。例如,它可以通过添加自定义属性和方法来增强代码的功能性和可扩展性。它还提供了一个图形用户界面,交互式配置和操作工具,使开发人员可以轻松地定制和管理应用程序的混淆过程。 总之,Dotfuscator 4.9是一款功能强大的.NET应用程序混淆器,为开发人员提供了保护源代码和知识产权的重要工具。它通过混淆、加密和删除不必要的元数据,有效地提高了应用程序的安全性。通过使用Dotfuscator 4.9,开发人员可以更加自信地发布他们的.NET应用程序,而无需担心源代码被恶意攻击和逆向工程。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值