zoj_1949 Error Correction

A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here's a 4 x 4 matrix which has the parity property:

1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1

The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2. 

Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt.


Input

The input will contain one or more test cases. The first line of each test case contains one integer n (n < 100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.


Output

For each matrix in the input file, print one line. If the matrix already has the parity property, print "OK". If the parity property can be established by changing one bit, print "Change bit (i,j)" where i is the row and j the column of the bit to be changed. Otherwise, print "Corrupt".


Sample Input

4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0


Sample Output

OK
Change bit (2,3)
Corrupt


分析:

        本题是判断一个矩阵是否具有奇偶性,这点只需计算每行每列的和是否是偶数即可。 但还需要判断一个没有奇偶性的矩阵是否可以通过修改唯一一位来是指具有奇偶性,这是难点。因为是修改一位,所以这一位既导致所在行的和是奇数,也导致所在列的和是基数。也就是当只有一行的和是奇数且只有一列的和是奇数时,将行与列交点处的元素修改一下,就变成parity property(奇偶性)的矩阵了。

       注意:如果定义一个过大的数组或容器,应当把它们定义为全局变量,这样可以获得尽可能到的内存分配。这种情况,不宜定义为函数内的局部变量。


答案:

<pre name="code" class="cpp">#include<iostream>
#include<cstring>
using namespace std;
int matrix[100][100];
int SR[100];
int SC[100];

void init()//为数组划分内存空间,且每个字节初始化为0
{
    memset(matrix,0,sizeof(matrix));//需要引入<cstring>
    memset(SR,0,sizeof(SR));//memset需被函数调用,不能在函数外执行
    memset(SC,0,sizeof(SC));
}
int main()
{
    int n,PR,PC,countR,countC;//n矩阵行(列)数,PR、PC是和为奇数的行号、列号,countR、countC是和为奇数的行数、列数
    int i,j;
    while(cin>>n)
    {
        if(n==0) break;//读入数据结束
         init();
        PR=0;
        PC=0;
        countR=0;
        countC=0;
        for(i=0;i<n;i++)//读入所有数据,同时计算出每行、每列的和
        {
            for(j=0;j<n;j++)
            {
                cin>>matrix[i][j];
                SR[i]=SR[i]+matrix[i][j];
                SC[j]=SC[j]+matrix[i][j];
            }
        }
        for(i=0;i<n;i++)//判断每行、每列的和是否是偶数
        {
            if(SR[i]%2!=0)//当前行的和是奇数
            {
                PR=i;//记录行号
                countR++;//记录次数
            }
            if(SC[i]%2!=0)//当前列的和是奇数
            {
                PC=i;//记录列号
                countC++;//记录次数
            }
        }
        //输出结果
        if(countR==0&&countC==0) cout<<"OK"<<endl;
        else if(countR==1&&countC==1) cout<<"Change bit ("<<PR+1<<","<<PC+1<<")"<<endl;
        else cout<<"Corrupt"<<endl;
    }
    return 0;
}

 
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值