1/21集训二 模拟+贪心 B.(模拟 改变布尔矩阵某点使其成为欧拉矩阵(每一行每一列之和为偶数))Error Correction

1/21集训二 模拟+贪心

B.(模拟 改变矩阵某点使其成为欧拉矩阵(每一行每一列之和为偶数))Error Correction

A boolean matrix has the parity property when each row and each column has an even sum, i.e. contains an even number of bits which are set. Here’s a 4 x 4 matrix which has the parity property:

1 0 1 0

0 0 0 0

1 1 1 1

0 1 0 1


The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2.
Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt.

Input
The input will contain one or more test cases. The first line of each test case contains one integer n (n<100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.
Output
For each matrix in the input file, print one line. If the matrix already has the parity property, print “OK”. If the parity property can be established by changing one bit, print “Change bit (i,j)” where i is the row and j the column of the bit to be changed. Otherwise, print “Corrupt”.
Sample Input

4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0

Sample Output

OK
Change bit (2,3)
Corrupt

题意:
给定一个布尔矩阵,判断其是否具有奇偶性(若每行每列之和均为偶数,则为欧拉矩阵),若不具有,是否能通过修改一个值来使其满足奇偶性。

思路:
修改:如果这个矩阵只有一行和一列的数字和为奇数,那么就可以通过修改这个行和这个列交点处这一点的值,来满足奇偶性,否则不可以。

#include <iostream>
#include <stdio.h>
#define MAXN 105
using namespace std;

int main()
{
    int n;
    while(scanf("%d", &n) != EOF)
    {
        if(n == 0)
            break;
        int a[MAXN][MAXN], flagh = 0, flagz = 0, sumh, sumz;
        int h, z;
        for(int i = 0; i < n; i++)
        {
            sumh = 0;
            for(int j = 0; j < n; j++)
            {
                cin>>a[i][j];
                sumh += a[i][j];
            }
            if(sumh % 2 != 0)
            {
                flagh++;
                h = i + 1;
            }
        }
        for(int j = 0; j < n; j++)
        {
            sumz = 0;
            for(int i = 0; i < n; i++)
            {
                sumz += a[i][j];
            }
            if(sumz % 2 != 0)
            {
                flagz++;
                z = j + 1;
            }
        }
        if(flagh == 0 && flagz == 0)
        {
            cout<<"OK"<<endl;
        }
        else if(flagh = 1 && flagz == 1)
        {
            cout<<"Change bit ("<<h<<','<<z<<')'<<endl;
        }
        else
            cout<<"Corrupt"<<endl;
    }
    return 0;
}

补充(欧拉图):
如果图G中的一个路径经过每条边恰好一次(”一笔画”), 则该路径
称为欧拉路径(Euler path)。
• 如果一个回路是欧拉路径,则称为欧拉回路(Euler circuit)。
• 欧拉图—具有欧拉回路的图
性质:
一个连通图每个点的出度和入度都是偶数=>欧拉图
=>“可以一笔画成

矩阵可以表示一个图(邻接矩阵)
• Array[ i][ j]=1表示 i到 j有一条有向边, 0表示 i 到 j 没有有向边。
• 第 i行1的个数表示 i的出度,同理第j列1的个数表示 j的入度
• 欧拉图—具有欧拉回路的图
分析:
• 题目要求矩阵的每一行,每一列,的1的个数都是偶数;也就是每个点
的出度和入度都是偶数=>欧拉图
• 对一有向欧拉图,求欧拉回路,即从点s出发,最终到达点s,每条边
走且仅走一次
• 深度优先搜索

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值