Find The Multiple——简单搜索+大胆尝试

【题目描述】

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

【题目分析】
看到这道题的第一反应是好像要用高精度,但是自己高精度又不太熟,所以就上网看了一下题解,发现并不用高精度就可以做出来,应该是数论什么的保证了有正确性或者是数据比较水?
得到的经验就是:看到一道题思考要用可能要用什么算法是对的,但是不能因为局限在这种可能性中停滞不前,可能的话还有不出现的概率呢,先试一下,比赛是即时反馈的,做出来才是王道。

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

typedef unsigned long long ll;
ll n,flag,t,p;

void BFS()
{
	queue<ll> q;
	t=1;
	q.push(t);
	while(!q.empty())
	{
		t=q.front(); q.pop();
		if(t%n==0)
		{
			printf("%llu\n",t);
			return;
		}
		p=t*10; q.push(p);
		p=t*10+1; q.push(p);
	}
}

int main()
{
	while(~scanf("%d",&n) && n)
	{
		flag=0;
		BFS();
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值