Find The Multiple

传送门

题面:

Find The Multiple

Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 45740
Accepted: 19128

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

题面描述:

给出一个整数n,(1 <= n <= 200)。求出任意一个它的倍数m,要求m必须只由十进制的0或1组成。

题目分析:

不知道为什么我用STL中的queue用C++交超时,而用G++就A了
,而写的结构体用C++交就过了。这题和二叉树差不多,从后往前分辨有末尾补上1和补上0的情况一直往下讨论再对n取模,满足直接输出。

代码:

C++:

#include<algorithm>
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
int n;
struct node{
    long long int x;
} q[10000001];
struct node t,f;
void bfs(){
    int s=0;
    int e=0;
    t.x=1;
    q[e++]=t;
    while(s<e){
        t=q[s++];
        if(t.x%n==0){
            printf("%lld\n",t.x);
            break;
        }
        f.x=t.x*10;
        q[e++]=f;
        f.x=t.x*10+1;
        q[e++]=f;
    }
}
int main(){
    while(scanf("%d",&n)!=EOF&&n!=0){
        bfs();
    }
    return 0;
}

G++:

#include<algorithm>
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
int n;

void bfs(int n){
	queue<long long> q;
    q.push(1);
    while(!q.empty()){
        long long tmp=q.front();
        q.pop();
        if(tmp%n==0){
            cout<<tmp<<endl;
            break;
        }
        q.push(tmp*10);
        q.push(tmp*10+1);
    }
}
int main(){
    while(cin>>n&&n){
        bfs(n);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Yjonben

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值