Catch That Cow



Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:   N  and   K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

人在n处,牛在k处,人一次可以到加一,减一,或乘以2的位置上,求到牛的最短时间。感觉用了dp做,和搜索的思想类似吧,每次进队列,然后搜索+1,-1,乘2的位置,然后反复,一直到k处,跳出循环,注意每次判断要加上限定,不然会越界。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
using namespace std;
int dp[100005], leap[100005];
queue<int>p;
int main()
{
	int i, j, m, n, ans, k,temp;
	cin >> temp >> k;
	memset(leap, 0, sizeof(leap));
	dp[k] = -1; dp[temp] = 0; leap[temp] = 1;
	p.push(temp);
	while (p.size())
	{
		n = p.front();
		if (!leap[n + 1]&&n+1<=100000&&n+1>=0)
		{
			leap[n + 1] = 1;
			dp[n + 1] = dp[n] + 1;
			p.push(n + 1);
		}
		if (!leap[n - 1]&&n-1>=0&&n-1<=100000)
		{
			leap[n - 1] = 1;
			dp[n - 1] = dp[n] + 1;
			p.push(n - 1);
		}
		if (n * 2 <= 100000&&n*2>=0)
		{
			if (!leap[2 * n])
			{
				leap[2 * n] = 1;
				dp[2 * n] = dp[n] + 1;
				p.push(2 * n);
			}
		}
		p.pop();
		if (dp[k] != -1)break;
	}
	cout << dp[k] << endl;
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值