1146 Topological Order (25 分) 拓扑序列是否合法

1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

题意:给定n个结点,m条有向边的拓扑图。

k个询问,问该序列是否合法。

输出不合法的序列编号(从0开始编号) 

思路:用vector存有向边,用degree数组记录结点的入度。

每次询问重置td数组(结点的入度),每输入一个数就判断该结点的入度是否为0.

若否则该序列不合法,flag修改为1。

且将改点指向的结点的入度--

#include <stdio.h>
#include <string.h>
#include <string>
#include <map>
#include <vector>
#include <queue>
#include <math.h>
#include <algorithm>
#include <iostream>
#define INF 0x3f3f3f3f
using namespace std;
vector<int> a[1005];//单向图 
int degree[1005],td[1005];//入度
vector<int> p;//输出的编号 
int main()
{
	int n,m,i,j,l,k,x,y;
	scanf("%d%d",&n,&m);
	memset(degree,0,sizeof degree);
	for(i=0;i<m;i++)
	{
		scanf("%d%d",&x,&y);
		a[x].push_back(y);
		degree[y]++;
	}	
	scanf("%d",&k);
	for(i=0;i<k;i++)
	{
		for(j=1;j<=n;j++)
		td[j]=degree[j];
		int flag=0;
		for(j=0;j<n;j++)
		{
			scanf("%d",&x);
			if(td[x]!=0) flag=1;
			for(l=0;l<a[x].size();l++)
			td[a[x][l]]--;
			
		}
		if(flag) p.push_back(i);
	}
	for(i=0;i<p.size();i++)
	{
		if(i)printf(" ");
		printf("%d",p[i]);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值