hdu 6182A Math Problem/2017ACM/ICPC广西邀请赛

A Math Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 318    Accepted Submission(s): 152


Problem Description
You are given a positive integer n, please count how many positive integers k satisfy  kkn .
 

Input
There are no more than 50 test cases.

Each case only contains a positivse integer n in a line.

1n1018
 

Output
For each test case, output an integer indicates the number of positive integers k satisfy  kkn  in a line.
 

Sample Input
  
  
1 4
 

Sample Output
  
  
1 2
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6193  6192  6191  6190  6189 
 

Statistic |  Submit |  Discuss |  Note

最多15,直接打表就行

需要注意的是15^15

pow(15,15)=437893890380859392

pow(15,7)*pow(15,8)=437893890380859375

坑啊

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <string.h>
#include <map>
#include <set>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
#include <stack>
#include <stdlib.h>
#define lowbit(x) (x&-x)
#define e exp(1.0)
#define eps 1e-8
//ios::sync_with_stdio(false);
//    auto start = clock();
//    cout << (clock() - start) / (double)CLOCKS_PER_SEC<<endl;
typedef long long ll;
typedef long long LL;
using namespace std;
typedef unsigned long long ull;
ll a[20]={1,4,27,256,3125,46656,823543,16777216,387420489,10000000000,285311670611,8916100448256,302875106592253,11112006825558016,437893890380859375};
int main()
{
    //cout<<(ll)pow(15,15)<<endl;
    //cout<<(ll)pow(15,7)*(ll)pow(15,8);
    ll n;
    //for(int i=1;i<16;i++)
    //cout<<','<<(ll)pow(i,i);
    while(cin>>n)
    {
        int ans=0;
        for(int i=0;i<15;i++)
        {
            if(n<a[i])
                break;
            ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值