HDU6182-A Math Problem

234 篇文章 1 订阅

A Math Problem

                                                                   Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                             Total Submission(s): 729    Accepted Submission(s): 305


Problem Description
You are given a positive integer n, please count how many positive integers k satisfy  kkn .
 

Input
There are no more than 50 test cases.

Each case only contains a positivse integer n in a line.

1n1018
 

Output
For each test case, output an integer indicates the number of positive integers k satisfy  kkn  in a line.
 

Sample Input
  
  
1 4
 

Sample Output
  
  
1 2
 

Source
 


题意:给你一个n,求有多少个k满足k^k<=n

解题思路:暴力即可


#include <iostream>  
#include <cstdio>  
#include <string>  
#include <cstring>  
#include <algorithm>  
#include <queue>  
#include <vector>  
#include <set>  
#include <stack>  
#include <map>  
#include <climits>  
#include <functional>  

using namespace std;

#define LL long long  
const int INF = 0x3f3f3f3f;

LL n;

LL qpow(LL x, LL y)
{
	LL ans = 1;
	while (y)
	{
		if (y & 1) ans *= x;
		y >>= 1;
		x *= x;
	}
	return ans;
}

int main()
{
	while (~scanf("%lld", &n))
	{
		int sum = 0;
		for (long long i = 1; i <= 15; i++)
		{
			if (qpow(i, i) > n) break;
			sum++;
		}
		printf("%d\n", sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值