PAT 1063 Set Similarity [set]

Given two sets of integers, the similarity of the sets is defined to be N​c​​/N​t​​×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​) and followed by M integers in the range [0,10​9​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

----------------------------------这是题目和解题的分割线----------------------------------

求交集/并集,所以要用set剔除重复元素。

#include<cstdio>
#include<set>

using namespace std;

int main()
{
	set<int> s[54];
	int n,x,i,num;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		scanf("%d",&x);
		while(x--)
		{
			scanf("%d",&num); 
			s[i].insert(num);
		}
	}
	int q,a,b;
	scanf("%d",&q);
	while(q--)
	{
		scanf("%d%d",&a,&b);
		int count = 0;
		//set只能通过迭代器访问,不可以数组下标 
		for(set<int>::iterator it=s[a].begin();it!=s[a].end();it++)
			//没找到 !=s[b].end()(左闭右开end不存数据) 
			if(s[b].find(*it)!=s[b].end()) count++;
		//并集元素=两个集合相加-重复元素 
		printf("%.1f%%\n",1.0*100*count/(s[a].size()+s[b].size()-count));

	}
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值