2017 多校训练第二场 HDU 6045 Is Derek lying?(思维)

Is Derek lying?

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2109    Accepted Submission(s): 1014


Problem Description
Derek and  Alfia are good friends. Derek is Chinese,and  Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of  N choice questions and each question is followed by three choices marked “ A” “ B” and “ C”.Each question has only one correct answer and each question is worth  1 point.It means that if your answer for this question is right,you can get  1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell  Derek the total score of him and  Alfia.Then  Alfia will ask  Derekthe total score of her and he will tell her: “My total score is  X,your total score is  Y.”But  Derek is naughty,sometimes he may lie to her. Here give you the answer that Derek and  Alfia made,you should judge whether  Derek is lying.If there exists a set of standard answer satisfy the total score that  Derek said,you can consider he is not lying,otherwise he is lying.
 

Input
The first line consists of an integer  T,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers  N, X, Y,the meaning is mentioned above.

The second line consists of  N characters,each character is “ A” “ B” or “ C”,which represents the answer of  Derek for each question.

The third line consists of  N characters,the same form as the second line,which represents the answer of  Alfia for each question.

Data Range: 1≤N≤80000, 0≤X,Y≤N, \sum_{i = 1}^{T} N≤300000
 

Output
For each test case,the output will be only a line.

Please print “ Lying” if you can make sure that  Derek is lying,otherwise please print “ Not\ lying”.
 

Sample Input
  
  
2 3 1 3 AAA ABC 5 5 0 ABCBC ACBCB
 

Sample Output
  
  
Not lying Lying
 

Source

题意:有两个人做题。其中一个人知道两个人到底对了多少题。那个人告诉另外一个人他们分别对了多少题,如果没有一种参考答案满足他说的那种情况就说明他说谎。否则他没说谎。

思路:
先找出两个人有多少个答案不同cnt。
1.x-y的绝对值是两个人回答正确的题数的差的绝对值,这个值一定会小于cnt。
2.x+y是两个人回答正确题数的和,这个值一定小于n+n-cnt。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int f(int x,int y)
{
    return x>y?x-y:y-x;
}
const int maxn=100000;
int main()
{
    int t;
    char a[maxn],b[maxn];
    while(~scanf("%d",&t))
    {
        int n,x,y;
        while(t--)
        {
            int cnt=0;
            scanf("%d%d%d",&n,&x,&y);
            scanf("%s",a);
            scanf("%s",b);
            for(int i=0;i<n;i++)
            {
                if(a[i]!=b[i])
                    cnt++;
            }
            if(x+y>2*n-cnt||cnt<f(x,y))
                printf("Lying\n");
            else
                printf("Not lying\n");
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值