hdu 5914 Triangle (斐波那切数列)

Triangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2113    Accepted Submission(s): 1205


Problem Description
Mr. Frog has n sticks, whose lengths are 1,2, 3 n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.
 

Input
The first line contains only one integer T ( T20 ), which indicates the number of test cases. 

For each test case, there is only one line describing the given integer n ( 1n20 ).
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.
 

Sample Input
  
  
3 4 5 6
 

Sample Output
  
  
Case #1: 1 Case #2: 1 Case #3: 2
 

Source
 

Recommend
wange2014

题意:

给了n个线段长度从1到n。问从中最少取走多少个线段能使得剩下的任意三个线段不能组成一个三角形。

思路:

三角形的的必要条件是两边之和大于第三边。而充分必要的话可以是最小的两条边加起来大于第三条边。所以构造的思路就出来了。我们用最小的两条边加起来得到第三条边的长度,这样就能刚好满足这三条边不能构成一个三角形。

所以其实就是一个斐波那切数列。

我们把斐波那切数列里面的数记录下来,从1-n遍历一次,发现不是其数列里面的数就把它剔除,记录一下就行了。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;
map<int,int>mp;
int main()
{
    int f[20],t,n,cas=1;
    f[0]=1;
    f[1]=1;
    mp[1]++;
    for(int i=2;i<=7;i++)
    {
        f[i]=f[i-1]+f[i-2];
        mp[f[i]]++;
    }
    /*f[2]=2;
    f[3]=3;
    f[4]=5;
    f[5]=8;
    f[6]=11;
    f[7]=19;
    int t,n;*/
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            if(mp[i]==0)
                ans++;
        }
        printf("Case #%d: %d\n",cas++,ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值