Least Common Multiple(最小公倍数)

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
23 5 7 156 4 10296 936 1287 792 1
 

Sample Output
10510296
#include<stdio.h>
int yueshu(int a,int b)
{
    int r;
    int temp;
    if(a<b)
    {
        temp=a;
        a=b;
        b=temp;
    }

    while(a%b!=0)
    {
        r=a%b;
        a=b;
        b=r;
    }

    return b;
}
int beishu(int a,int b)
{
    int yue;
    yue=yueshu(a,b);

    return (a/yue)*(b/yue)*yue;
}
int main()
{
    int a[50];
    int n;
    int i;
    int x,t;

    scanf("%d",&t);

    while(t--)
    {
        scanf("%d",&n);

        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }

        if(n==1)
        {
            printf("%d\n",a[0]);
            continue;
        }

        x=beishu(a[0],a[1]);

        for(i=2;i<n;i++)
        {
            x=beishu(x,a[i]);
        }

        printf("%d\n",x);
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值